Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I made my changes on nvidia-settings and also writed the changes to xorg.conf (yes, I checked the file).

After rebooting the settings are only applied after I open nvidia-settings agains, any way I can fix this? Right now I'm running this bs at startup: timeout 1 nvidia-settings

Happens with all available drivers (nouveau, current/experimental). The original --load-config-only that was on startup doesn't work.

share|improve this question
Have you tried to open the nvidia-settings as a root ? gksudo nvidia-settings . – NikTh Dec 14 '12 at 21:48
Yes, you can only write those changes with privileges. All the files are getting written since I can see the file AND like I said I can also load it when I open nvidia-settings, but it's supposed to work with --load-config-only too – braindamage Dec 14 '12 at 23:17
Maybe the behavior changed or maybe it is a bug. So with root privileges works as it should (?). – NikTh Dec 15 '12 at 4:27
I can't understand your comment, but if it's about running the same commands as root/sudo/gksudo I tried it all. Not even sudo nvidia-settings --load-config-only works, I also tried recompiled drivers. – braindamage Dec 15 '12 at 13:32


After using the nvidia-settings GUI just as user, edit the ~/.nvidia-settings-rc user file, and remove your host name prefix from all lines, leaving just ":" to start those lines. Just use replace all (your hostname) to nothing, in most editors.

Then, optionally set the file to read only; to lock any further changes. Otherwise nvidia-settings GUI changes will add your host name back to the file.

Or you can rename the edited file, and tell nvidia-settings to use it when loading: nvidia-settings -l --config=/home/user/my_edited_nvidia_settings_rc

You just have to remember to set the file to read and write, to unlock your settings, so the GUI will change them again, if needed. Alas, then, you have to remove the hostnames from it again.

I use this to set a correct gamma/color (green cast) for photography editing, with Nvidia cards. My monitor settings don't do it right.

Why removing hostname works, I don't know; but it does! Now I don't have to close the auto loaded nvidia-setting dialog every time I boot up (without the "-l"), and the darn "-l" (that's an L for load only) option works; when nvidia-setting -l is loaded as a startup application.

share|improve this answer
that exact tip solved for me :) – igorsantos07 Jun 24 '14 at 3:40
just created a bug about this here: – igorsantos07 Jun 24 '14 at 4:03

nvidia-settings seems still to be unsolved. it is not working here either.

if you need full screen for nvidia - then here is my answer:

xrander problem with 1900x1080p

I tried with this to solve nvidia-settings-frickle too, - but it did not help here. You can test if this helps at your machine ?!

share|improve this answer
I don't have any problems with the resolution settings (I think the xorg.conf is actually getting loaded, just not the .nvidia-settings-rc). It's just gamma, brightness, etc.. and probably AA settings but I don't have any game here to confirm it – braindamage Dec 14 '12 at 20:21

I'm in the same problem and came with a half (or quarter of a...) solution.

Simply issue in the terminal these commands:

$ nvidia-settings & sleep 2 && killall -v nvidia-settings

or for more convenience, you could place this on the desktop in a executable bash script:

#! /bin/bash

nvidia-settings & sleep 2 && killall -v nvidia-settings

I didn't got luck issuing this script on Startup preferences nor in .profile file on user home folder. If I use this script on .profile, desktop environment loading waits for the whole script execution (when using something like

#! /bin/bash

sleep 15
nvidia-settings & sleep 2 && killall -v nvidia-settings

...) and when it finishes, seems like that the right settings in .nvidia-settings-rc are overriden by something else

But in the meantime I have a quick way to apply my color correction.


share|improve this answer

I've got the same problem. Don't know the answer for sure. I think it has something to do with loading the .nvidia-settings-rc file when you log in. That is just my guess.

This link might help also:


share|improve this answer
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Aditya Feb 11 '13 at 12:55
Alas this does not help. nvidia-settings silently exits. – Joseph Garvin Apr 9 '13 at 23:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.