Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

According to post #15 of this Ubuntu Forums thread about Nautilus being slow, turning off global menu speeds Nautilus up significantly. This is certainly true for me, as running Nautilus as root makes it a few times (!) faster (with no gnome-scripts installed, cache cleared, Dropbox turned off).

Now, I like the global menu--but I also want Nautilus to be fast! Is there a way to turn off the global menu only for Nautilus?

share|improve this question

2 Answers 2

You can try this:

  • Create a litte script in (/usr/bin), go to the terminal and type:

    cd /usr/bin

    sudo gedit nautilusappmenu.sh

  • In the script add these lines:

    #! /bin/bash
    UBUNTU_MENUPROXY=0
    nautilus -n

  • Change the permissions to 775:

    sudo chmod 755 /usr/bin/nautilusappmenu.sh

  • Edit the nautilus desktop file in /etc/xdg/autostart/ folder. First make a backup of the .desktop,in the terminal type:

    cd /etc/xdg/autostart

    sudo cp nautilus-autostart.desktop nautilus-autostart.desktop.bak

    sudo gedit nautilus-autostart.desktop

    Find the line "Exec=nautilus -n" and change it to "Exec=/usr/bin/nautilusappmenu.sh"

enter image description here

  • Finally log out and log in to see the changes.

If anything goes wrong remember you have a backup of the nautilus-autostart.desktop file, or just edit the line "Exec=/usr/bin/nautilusappmenu.sh" to "Exec=nautilus -n" from any TTY.

Hope this will solve your problem.

Regards.

share|improve this answer

You can disable the global menu in Nautilus.

  1. Open a terminal and type gksudo gedit /usr/share/applications/nautilus.desktop
  2. Find the line Exec=nautilus %U and change it to Exec=UBUNTU_MENUPROXY=0 nautilus %U
  3. Save and exit
  4. Kill Nautilus by opening Nautilus, press Alt + F2, type xkill, click the Nautilus window.
  5. Launch Nautilus again. No more global menu.

Now launching nautilus should have the global menu disabled.

EDIT

I just realised that this method works with other programs but not with Nautilus bacause Nautilus is launched at startup. This is not a direct answer to your question but if you want a faster file manager, you might consider installing Thunar.

share|improve this answer
    
Doesn't work for me. The icon just keeps pulsing and nautilus won't open... –  Syzygy Dec 15 '12 at 4:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.