Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
My computer boots to a black screen, what options do I have to fix it?

I have the problem on my ThinkPad T520 with Nvidia Optimus and SSD drive

Problem occurs with bumblebee installed and also without bumblebee, nvidia-current, bumblebee-nvidia packages. After reboot once or more it's ok.

In BIOS video is set to Optimus and "Detect by system" is disabled.

There are 3 cases when I can notice this behaviour:

  1. When I start computer. Can't see login box, just mouse and black screen. Several reboot helps.
  2. When my computer is waking on from suspending state.
  3. When I use only external display and watching a movie. After 20 mins of inactivity external display is turning off. When I press any key no screen either.

It was working ok on my ubuntu 12.04 upgraded to 12.10.

I bought new SSD drive and installed fresh ubuntu 12.10 when the problem has started occuring.

share|improve this question
    
During this behaviour I got error like: [ 3.366] (==) No monitor specified for screen "Default Screen Section". Using a default monitor configuration. –  Michal Dec 14 '12 at 15:41
add comment

marked as duplicate by Jorge Castro, Tom Brossman, hhlp, fabricator4, Ringtail Dec 14 '12 at 23:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

This problem has occurred several times here on ubuntu since 12.10:

the answer of this problem could help ?:

xrander problem with 1900x1080p

regards. dschinn1001

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.