Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used to mount my local network HDD (samba share) using following fstab entry:

//192.168.1.5/PUBLIC /media/MyBookLive smbfs credentials=/home/gacek/.mybookcredentials,uid=1000,gid=1000

Of course, the .mybookcredentials file contains authentication details for user with full rights. It used to work in 12.x, but I had to reinstall my Ubuntu and right now (in 11.10) it mounts the share in read-only mode.

I also tried to replace smbfs with cifs with no result.

How can I mount my samba share (via fstab) with write permissions?

SOLVED

OK, I haven't noticed that my GID changed. After checking my UID using:

id -u username

And replacing with it the UID and GID in fstab file all works - I have read-write permissions to my mounted samba disc.

share|improve this question

1 Answer 1

Try adding the "defaults" option

//192.168.1.5/PUBLIC /media/MyBookLive cifs defaults,credentials=/home/gacek/.mybookcredentials,uid=1000,gid=1000

or the "rw" option.

//192.168.1.5/PUBLIC /media/MyBookLive cifs rw,credentials=/home/gacek/.mybookcredentials,uid=1000,gid=1000
share|improve this answer
    
After adding defaults or rw it says that the line is incorrect –  Gacek Dec 14 '12 at 21:22
    
I just tested similar lines and had success, but only if I used 'cifs' instead of 'smbfs'. I have updated the answer accordingly. –  jdthood Dec 14 '12 at 21:34
    
Sorry, still it says there's some error. I found where was my mistake - see my update. so the question is solved –  Gacek Dec 14 '12 at 22:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.