Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to know how to make GDM to autologin with the default (and only) account. I use it with Gnome3 on my 2 machines (one with 12.04 and the other with 11.10).

I have selected to auto-login on the System Settings but it doesn't work.

PS: Installing kdm or lightdm is not a solution since I prefer GDM.

share|improve this question

1 Answer 1

GDM on these systems has a bug but there is a workaround.

Open the file with editors whichever you'd like to use:

gksu gedit /etc/gdm/custom.conf

Add these options to that file like this:

# GDM configuration storage
#
#See /usr/share/gdm/gdm.schemas for a list of available options.

[daemon]
#Enabling automatic login
AutomaticLoginEnable = true
AutomaticLogin = YOUR_ACCOUNT_NAME
.  
.

Then save and reboot and check if your machine could accept "auto-login" as normally...

Hope this helps source

share|improve this answer
    
There is no custom.conf file. Can I safely create one or will this overwrite the other PostSession PostLogin and PreSession folder/files ? –  aliasbody Dec 14 '12 at 17:26
    
Create a new custom configuration. If it does not work what is there to loose. YOU CAN ALWAYS DELETE THAT. –  Ringtail Dec 14 '12 at 23:18
    
should be #Enabling automatic login –  palindrom Aug 7 '13 at 6:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.