Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

here's my problem:

Ever since I installed Ubuntu 12.10 on my computer I haven't been able to change the screen brightness, it was always set to the maximum. I did take a look at this post:

Decrease Backlight Below Minimum

And it helped me resolved the issue with the unbearable brightness, however one problem persists: I cannot change it through "Brightness & Lock" or the function buttons (F2 and F3), when I press the buttons, the animation shows up but nothing happens. I tried the following:

http://www.refreshit.info/2012/08/solved-brightness-increase-and-decrease.html

It did nothing...

If it helps:

I have an HP-dv6 6185la, it has an ATI Radeon 6770M HD card and an Intel HD Integrated Graphics Card

It only detects the "Intel® Sandybridge Mobile"

Thanks in advance.

share|improve this question

4 Answers 4

up vote 18 down vote accepted

What worked for me was to change the /etc/default/grub file as follows:

  • Open a terminal (Ctrl + Alt + T) and type sudo gedit /etc/default/grub

  • Find the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and modify it to one of the following:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

    or

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor" (try this if the first one doesn't work)

  • Save and close gedit.

  • Then type sudo update-grub
  • Reboot your pc.

EDIT

As from Ubuntu 13.10, this did not solve the problem for me on a Toshiba laptop. I needed one extra step for the problem to be solved.

I had to create an xorg.conf file in /etc/X11/ with the following contents:

Section "Device"
       Identifier      "Configured Video Device"
       Driver          "intel"
       Option          "Backlight"       "intel_backlight"
EndSection
#
Section "Monitor"
       Identifier      "Configured Monitor"
EndSection
#
Section "Screen"
       Identifier      "Default Screen"
       Monitor         "Configured Monitor"
       Device          "Configured Video Device"
EndSection

WARNING!! Getting the file wrong or if this configuration is not compatible with your hardware, might end up with an unbootable system! It happened to me.

In that case, you'll have to delete (or rename) the file, but to do so requires either booting from a liveUSB or liveDVD (the simplest way) or booting in recovery mode, making the Ubuntu partition rewritable and then delete the offending xorg.conf file.

share|improve this answer
    
Thanks for your kind assistance, it worked!! –  user1793249 Dec 14 '12 at 17:06
    
This also works on 13.04, in case someone else is having the same issue. –  godfrzero Aug 5 '13 at 18:14
    
The second one with acpi_osi=Linux worked on Debian too, thanks :> –  Stichoza Dec 24 '13 at 23:51
    
It worked for me on HP Elitebook 8470p with Ubuntu 12.04 –  David Jacquel Jan 15 at 9:04
    
worked on 14.04 for me, i had the second option in my grub file from 13.* already. the xorg.conf saved the day –  RichardJohnn Mar 26 at 3:12

I was do the same as above.

It was do nothing.

Then I had to leave my g75VW and closed the lid.

I come back after a while then I opened the lid and then the backlight was working with F5/F6 as it should be…

Only the onscreen display not showing…

I tried again with lid closing and after a while open it and it still working..

Hope it's helps.

share|improve this answer

Try this, it helped me with intel gpu http://ubuntufixer.blogspot.com/2012/12/set-screen-brightness-at-start-up.html

share|improve this answer
3  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eliah Kagan Dec 19 '12 at 1:30

I tried several solutions, including changing grub, xbacklight, and several others. The method that works for me is changing NVIDIA settings.

  1. In terminal, gksudo gedit /etc/X11/xorg.conf
  2. Add line Option "RegistryDwords" "EnableBrightnessControl=1" immediately above EndSection
  3. Save and reboot

Here is the original page:

https://wiki.archlinux.org/index.php/NVIDIA#No_brightness_control_on_laptops

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.