Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I recently upgraded to 12.10 (fresh install). I am a facing weird problem:

When I boot, I get a message notifying me of low graphics. For now, I have been switching to console using Alt+F1 and then rebooting.

Upon reboot, I select recovery mode, allow system to boot and then again reboot.

Now I select normal mode and my graphics load smoothly.

Could you please tell me what could be the issue? I have a Dell Inspiron 5230 with Intel 4000 onboard graphics.

share|improve this question

marked as duplicate by Eliah Kagan, stephenmyall, Alvar, Kevin Bowen, Eric Carvalho Aug 17 '13 at 3:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 3 down vote accepted

It has absolutely nothing to do with the GPU. It's a problem with LightDM and SSDs (or some other "abnormally fast" piece of hardware, Nvidia cards cause the same issue)

Try adding



stop on runlevel

In /etc/init/lightdm.conf

Often times, if you run into this error, you can hit

[Ctrl] + [Alt] + [5] to enter a terminal. Login and try

sudo lightdm start

If that doesn't yield anything try

sudo service lightdm restart

As a side note, my SATAIII SSD was connected to the SATAII port on my logic board when I ran into this issue. Verify that your main SSD is on the correct port before you try anything.

share|improve this answer
Great answer, thank you. I have a SSD (SATAIII connected to SATAII port) + NVIDIA GPU , and I had this very annoying problem, and had to reboot several times before the GUI showed up (sometimes it booted into the command line, but recently that "low graphics" thing has been showing up instead). That "respawn" command worked wonders, I never had the problem again. I'm using Ubuntu 12.04. Thank you very much. – faken Jun 11 '13 at 16:41

Your question appears similar to this one although you mention you have an Intel GPU (it could be unrelated).

Basically, it looks like LightDM (the default greeter/login screen) can sometimes get a bit confused if you've installed other packages or something has gone wrong with its configuration.

Here is a relevant bug report, though possibly for a different version:

I think the best (least destructive) advice there is the following:

sudo dpkg-reconfigure unity-greeter
sudo dpkg-reconfigure lightdm

Hopefully that should fix it!

You could also make sure that the ubuntu-desktop metapackage is installed.

Some of the advice in that other question seems suspect to me, either because it involves installing random PPAs or it simply doesn't apply to people with Intel graphics.

share|improve this answer
I do not have any PPA installed, still it sometimes goes to low graphics mode. I will do reconfigure and let you know if that solves the problem. – Amey Jah Dec 19 '12 at 14:18

I gave this same answer here. If this situation applies to you, these seem good workarounds.

For Intel integrated graphics on Core processors, it seems that lightdm is the culprit and workarounds are add a delay in rc.local or install and use gdm. Launchpad seems to think that lightdm is too fast at querying for a display and people are saying SSDs can contribute to this race condition. Not sure if this would help you.

share|improve this answer

Try going into system settings, and under the "Additional Drivers" section, click on that. Their might possibly be an available driver for the card. I would use the recommended driver if any. That makes my graphics really smooth. Good luck!

share|improve this answer
It says no proprietary drivers are in use. I have intel 4000 graphics card. – Amey Jah Dec 18 '12 at 23:26
It must be 12.10. I upgraded my laptop to that, and an hour later i was back to 12.04. I find that 12.04 works best. – kyle_hamblett Dec 18 '12 at 23:30
OP said he has an Intel GPU. Proprietary drivers are not applicable. – thomasrutter Dec 18 '12 at 23:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.