Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

By default the key-mouse combination activates the window menu.

The "activate the window menu" shortcut is currently set to "alt+space."

The Alt-RMB key combo is used in blender for selecting edge loops.

share|improve this question

3 Answers 3

Install the compizconfig-settings-manager package and run ccsm. At General | General Options | Key bindings | Window Menu click on Alt<Button3>, de-select Enabled and click OK.

P.S. If this doesn't work, assign a different key to Window Menu. Thanks to Morichalion.

share|improve this answer
    
Doesn't work as written. When I switch tabs or windows, it resets the keybinding. I set it to another key, and that made the setting stick. –  Morichalion Dec 13 '12 at 22:01

Fix Alt-drag window move:


With Unity-2D (and now Gnome 3), this is controlled using the /apps/metacity/general/mouse_button_modifier GConf key. To disable Alt+Click dragging, run:

gconftool-2 --set /apps/metacity/general/mouse_button_modifier --type string '<Super>'

To re-enable it, run:

gconftool-2 --set /apps/metacity/general/mouse_button_modifier --type string '<Alt>'

Note that this GConf key controls several mouse shortcuts:

  • Alt+Click: Move windows

  • Alt+Middle Click: Resize windows

  • Alt+Right Click: Open a generic window menu

Alt-drag fix for gnome 3:
Here is the new fix:

sudo gconftool-2 --set /org/gnome/desktop/wm/preferences/mouse-button-modifier --type string '<Super>'

If that doesn't work, try this:

  1. install dconf-tools:

    sudo apt-get install dconf-tools
    
  2. Then run:

    dconf-editor
    
  3. Then navigate to:

    org → gnome → desktop → wm → preferences → mouse-button-modifier
    
  4. Change the value to:

    <Super>

  5. Close the dconf-editor window.

Why this should be necessary when there's a dialogue for system hotkeys under keyboard preferences, is beyond me. Very frustrating having to hunt it down with each new release/update of gnome!

Source: Disable Alt for window move in gnome-shell

share|improve this answer
    
I set the value as "<Alt>+<Super>" so I can use 'Alt' in Inkscape and 'Super' for activities –  Crimbo Mar 17 '13 at 17:31

Try shift + alt + RMB. That was the best solution I could find. You can customized your keys in Blender's user preferences to change loop selection to something else too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.