Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

EDIT: after frustrations with this, I have decided to take an entire different route, I am no longer interested in this, but am not able to delete it. That said, the problem still exists, and maybe someone else could benefit from an answer to it.

My goal is to be able to use the numpad up and down as volume up and down. Notice I said numpad up/down not numpad 8/2, I should still be able to type an 8 and a 2 with the numpad when numlock is on.

When I run the command

xmodmap -e "keycode 88 = g KP_2 g KP_2"

I can type a g with numpad down and press the numlock and then type a 2 with numpad 2. This is as expected.

When I type

xmodmap -e "keycode 88 = XF86Calculator KP_2 XF86Calculator KP_2"

I get nothing when I press numpad down and get a 2 when I press numlock and then numpad 2. The command xev confirms that XF86Calculator is assigned to numpad down and that KP_2 is assigned to numpad 2. I then go to the Ubuntu keyboard shortcuts menu and under launchers I select the calculator, with numpad turned off I press numpad down and it registers that I have assigned to the calculator launcher the calculator key (now numpad down), that's great. When I press numpad down it launchers the calculator, just as it should. But then I press the num lock and press numpad 2 nothing happens. When I press numpad 2 with xev I no longer get KP_2 but instead I get this

FocusIn event, serial 41, synthetic NO, window 0x6600001,
mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 41, synthetic NO, window 0x0,
keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
       0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

The Ubuntu keyboard shortcuts did assign my shortcut properly but seems to be stopping me from typing a 2 with the numpad. I would also be happy assigning the volume controls to F* keys, but I would have to have a way to still use all my F* keys in other applications. I want to volume controls to be a single key, no key combinations. Thanks!

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.