Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently installed Ubuntu along with Windows Vista. So normally when the laptop is starting up it shows two options whether I want to log on Windows or Ubuntu. One day I shut down the laptop and I open it the next and it just logs onto Windows automatically without giving me the option to choose. I go to check if Ubuntu was un-installed or something, but it was still there and everything, but I can't open it. I don't know if there's any additional info I should add because I'm not very good with computers, and I don't want to re-install it because I have my stuff on it so I'd lose it, and I'm having trouble backing it up. Any suggestions?

share|improve this question
add comment

2 Answers 2

For some reason i don't know, looks like your MBR(Master Boot Record) has changed and replaced GRUB with Windows.

There are a few steps you can follow to recover the ability to boot Ubuntu again.

1) You need a DVD or a USB stick with Ubuntu into it. Boot the laptop from it. Choose to run, not to install Ubuntu.

2) Once there, check if all your data is there. Open Nautilus, the file explorer and look for you partitions.

3) Next open Terminal and run this command: sudo fdisk -l. It will show all available Hard Disks and partitions in you laptop. Choose the one you have installed Ubuntu. If you don't know which one, just post the results here and we will help you.

4) Only do this step if you know which partition contains Ubuntu! Run this on Terminal: sudo mount -t ext4 /dev/sdaX /mnt. Where sdaX is the partition number Ubuntu is in, and ext4 is the default file system.

5) Then run this last command: sudo grub-install --root-directory=/mnt /dev/sda

Any questions just post the results here.

share|improve this answer
add comment

Check the bios for startup alternatives. Press F12 (or whatever key that takes your computer to the BIOS settings) and check your startup/boot alternatives.

share|improve this answer
    
I tried that as well, didn't work. –  Jade Dec 14 '12 at 5:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.