Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Users out there,

I came here with the spark of a hope, that you could help me. I want to get rid of my old WinXP, because the Game-Support for it seems to slowly expire now... So I took a second drive, just an old empty one I had at hands (ATA-Maxtor 90648D3), plugged of the other drive with WinXP, so that it couldn't be harmed, and started the installationof Ubuntu 12.04. Everything went as it was supposed to, until the end. Normal shutdown after successful installation process. But when I tried to boot my new Ubuntu from the HDD, it said:

 error: out of disk.
   grub rescue>

So, what to do now? I already tried a lot of things in the terminal, e.g. the update-grub as mentioned on http://opensource-sidh.blogspot.de/2011/06/recover-grub-live-ubuntu-cd-pendrive.html. Everything worked, he didn't complain about a missing data or anything, but at the end of the day he still wasn't able to boot!

Next step was to change the etc/default/grub-file, so that it could load the ATA-drivers first, so that there is now problem with my drive. But even this didn't seem to have any effect, I'm still stuck with Ubuntu in the Live-CD-Mode...

If there was anybody to help me out there, I would be very glad.

Thanks for any support, Dave

P.S.: I even tried to fix it with boot-repair, a small tool for Ubuntu, and it created a file with data that could probably help you to help me. You can find it on http://paste.ubuntu.com/1428022/

UPDATE: at work i have a WDC WD3200YS-01PGB0 drive and everything is working. At home, I tried it with a ATA-Maxtor. The rest as above...

share|improve this question
    
If you are missing any relevant data to help me, please leave a comment, I'll be happy to provide them to you asap! –  Dave Dec 15 '12 at 15:16
    
While in your live CD are you able to browse your files in the two hard disks? Open a terminal and type sudo fdisk -l and add this data to your question. –  To Do Dec 20 '12 at 9:51
    
i can browse through the data without problems in gui-mode, but i'll also try out the terminal-thing. –  Dave Jan 11 '13 at 7:35

3 Answers 3

Fortunately, this is a very easy fix!

  1. Boot up into a live CD, preferable Ubuntu.
  2. Open a command line. You can do this by pressing ctrl+alt+T from anywhere in the Ubuntu GUI.
  3. run the command "sudo grub-install"

It will take like 2 seconds to finish and GRUB will be reinstalled.

share|improve this answer
    
i have already tried grub-install, as in my first given link, but i still have the same problem, sorry... –  Dave Jan 11 '13 at 7:37

Try following the grub rescue thats given here "click here".

I guess this should solve your problem!

share|improve this answer
    
i have already done a grub-update, it was "successfull", as he wanted me to know, but didn't change anything with the boot-problem. –  Dave Jan 11 '13 at 7:38
up vote 0 down vote accepted

So, I had some time for this problem again, so worked on it - and fixed it! It was very simple, but on an other layer than we thought. I just switched the jumper-positions on the HDD, and now it works. I suppose the HDD was registered as a slave, which is not for booting issues. So if you want to boot a OS from a drive, always make sure to have it included as master (1 or 2 doesn't matter, only master) so that the BIOS knows where to search. Thank you for your help, maybe those hints can help someone else searching for a solution!?

share|improve this answer
    
as the other ideas contributed here could be useful for others that didn't find this help anywhere else, I gave the two of you an upvote ;) –  Dave Mar 5 '13 at 8:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.