Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In the software centre the latest release of Miro available is 4.0.4 whereas the latest release of Miro is 5.0.4.

How do I download 5.0.4 on 12.10?

I have tried following the guide at http://www.getmiro.com/download/for-ubuntu/ (and thus have already run sudo add-apt-repository ppa:pcf/miro-releases) but it failed and when I tried to run sudo apt-get update I received the error:

W: Failed to fetch http://ppa.launchpad.net/pcf/miro-releases/ubuntu/dists/quantal/main/source/Sources  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/pcf/miro-releases/ubuntu/dists/quantal/main/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
share|improve this question
    
its all written in the link given by u. 1st do this in terminal - sudo add-apt-repository ppa:pcf/miro-releases Then open SYNAPTIC PACKAGE MANAGER. If u have not installed it install it from UBUNTU SOFTWARE CENTER. Open it press RELOAD and then search for miro. It will show the version 5.0.4-1 version. Then mark this and install. If update is not shown then remove the 1st one from software center and then install the new one! –  Arin Chakraborty Dec 13 '12 at 10:08
    
That repository doesn't exist whenever I add it and run sudo apt-get update I receive the error detailed in my question. –  Brenton Horne Dec 13 '12 at 10:10
3  
The repository doesn't have a version for 12.10 (Quantal). Check ppa.launchpad.net/pcf/miro-releases/ubuntu/dists to see the versions available –  jorgehsrama Dec 13 '12 at 10:12
    
i didnot notice that u said 12.10. @jorgehsrama is right. –  Arin Chakraborty Dec 13 '12 at 10:14

2 Answers 2

up vote 1 down vote accepted

Just change the source definition of the PPA from quantal to precise. For some reason Precise has the right version under packages and Quantal does not. This will definitely work for you.

share|improve this answer
1  
Thanks, mate, I'll give it a try. –  Brenton Horne Jan 31 '13 at 0:05
1  
It worked, thanks. –  Brenton Horne Jan 31 '13 at 0:19
    
glad to hear it worked out for you! It was driving me nuts personally until I dug deeper and then felt silly that it was such a simple issue. If anyone needs any personal help on how to perform this just shoot me a msg i can give you a breakdown. Miro seems to be the only podcast player that reliably keeps track of resume capabilities. –  da5id Jan 31 '13 at 19:13

As an update, note that the repository here:

ppa.launchpad.net/pcf/miro-releases/ubuntu/dists

now seems to include Miro for Ubuntu 12.10 Quantal. However, the latest version in the repository is 4.0.4 whereas I understand that Miro version 5.0.4-1 is available for earlier versions of Ubuntu (12.04). Not sure why this is the case.

Thanks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.