Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently I have installed ubuntu 12.10. It shows my bluetooth device & bluetooth icon. But I could not pair or send or receive any files using obex push. How could I resolve this? This is a big problem to me.

terminal output of lsusb:

Bus 001 Device 008: ID 413c:8160 Dell Computer Corp. Wireless 365 Bluetooth

The output of rfkill list all:

0: brcmwl-0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
1: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
share|improve this question
please, post the output of rfkill list all – Pavel A Dec 13 '12 at 8:11
output: 0: brcmwl-0: Wireless LAN Soft blocked: no Hard blocked: no 1: hci0: Bluetooth Soft blocked: no Hard blocked: no – Sazzad Dec 13 '12 at 9:51
Tried this myself. I could establish connection with the phone and partially remote-control the laptop, but could not 'Send files' or 'Browse' as well. I could not pair Does this mean you could not connect with the phone? Also after enabling Bluetooth in BIOS I have 'bluetooth' kernel module loaded: lsmod | grep bluetooth and when I turn it on in System Settings an additional entry in rfkill list appears. What about you? Do you have any Bluetooth-related modules loaded? – Pavel A Dec 15 '12 at 10:26

I had the same issue, But then figured it out that the network adapter was switched off with the explicit function key provided by the laptop manufacturer when I was using windows. The blue tooth in Ubuntu started working after it was enabled in the windows boot

share|improve this answer

I have experienced the same issue with 12.10. Under 12.04 "rfkill list all" displays the following for bluetooth:

2: dell-bluetooth: Bluetooth Soft blocked: no Hard blocked: no 4: hci0: Bluetooth Soft blocked: no Hard blocked: no

I have a dell M1210 running 12.04. I am able to pair and maintain bluetooth connection with my BT mouse. BT mouse connection works after resuming from suspend as well. When I installed 12.10 rfkill does not list "dell-bluetooth..." -- only "hci0: Bluetooth" is listed. Also in 12.10 bluetooth connection to my mouse must be repaired after resuming from suspend. I tested "rfkill block bluetooth" and noticed the bluetooth indicator light does not go off under 12:10 (it did under 12.04). I reinstalled 12.04 and bluetooth works perfectly.

Hope this helps troubleshoot.

share|improve this answer

Try installing 'Blueman blutooth manager' from Ubuntu Software Center and restart computer. It worked for me.

share|improve this answer

I am not sure "Blueman bluetooth manager" helps.

In my case, I tested with and without it. It seems random. Sometimes the bluetooth device will be found and will be working fine. Other times it won't even show up on hcitool dev, but it will be there on lsusb and it will be listed with all items as 'no' on rfkill list all.

When it does not work, I just restart the machine until eventually it works.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.