Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently updated to Ubuntu 12.04, from Ubuntu 10.04, and my Internet, USB760 Novetel Verizon-Wireless Mobile Broadband, will connect after a minute of me starting the computer up. But after a while it will disconnect and the only way to reconnect it is to restart the computer. Even then, sometimes it won't work.

I've also noticed that since I've upgraded the computer, the computer will randomly enter into Power Save mode, and then it will tell me to log back in. I've done nothing to provoke it, other than using the Internet. I was wondering, could the entering into Power Save mode and the Internet disconnecting be somehow connected? I've updated the computer every time it asks me to do so, but it doesn't seem to be helping. If Ubuntu 10.04 would still be supported by next year, I would downgrade. But I have no other choice than to stick with 12.04. Any help would be greatly appreciated! Thanks!

share|improve this question
    
I was having quite a similar issue. I think you first need check your hardware. In my case there were no problem in the OS rather my LAN Adapter was Faulty. I think you can try updating the kernel into a newer one. This might help. –  Curious Apprentice Dec 12 '12 at 21:24
    
The tag 'mobile' is specifically for issues around getting Ubuntu to work on tablets or smartphones. –  david6 Dec 14 '12 at 7:33

1 Answer 1

Your problem sounds like this bug:

https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/848164

Although the bug hasn't been fixed yet, a couple solutions have been posted. This one includes a step-by-step guide:

http://www.thefanclub.co.za/how-to/how-auto-connect-ubuntu-1204-gsm-mobile-broadband-connection-on-boot-startup-service

Regarding the power issues, I suspect the computer isn't going to sleep, although you can check power management settings by going to System Settings... (accessible by clicking the gear icon in the upper-right side of the screen) --> Power.

My suspicion rather is that your screen is going to sleep. You can adjust this by going to System Settings... --> Brightness and Lock. I wouldn't recommend completely disabling turning off your screen, but maybe instead set it to a longer time. You could also disable having to re-enter your password by turning Lock to off.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.