Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First of all, sorry for my bad English, as it isn't my primary language.

I have a home network with my Ubuntu box, a Windows XP box (sister's laptop) and a Windows 7 box (mother's PC). Never had a mixed network; with some effort I could install Samba and see the PCs (and be seen for them).

All Windows PCs can access Ubuntu, create and delete files and folders in the shared folders like a charm, and I can do the same with the Windows XP PC. From Ubuntu to Windows 7, however, I can't; a window requesting credentials appears, but there's nothing password-protected accounts in Windows 7. There's just one user account on that computer, without password.

How can I access this computer?

share|improve this question
    
What Windows 7 are you using? Remember that Windows Starter Edition does not allow sharing! –  user117312 Dec 28 '12 at 21:51
    
Hopefully isn't WSE. It's a Windows Professional. –  João Santana Dec 29 '12 at 12:51

4 Answers 4

up vote 1 down vote accepted
+50

If you want to access the Windows 7 computer without a password?


I suggest you disable "Password protected sharing" on the Windows 7 computer, and then specially allow Guest account to access the shared components.


To turn off Password Protected Sharing:

  1. Click Start, enter "Network and Sharing Center" in the Start Search box .
  2. Click "Change advanced sharing settings" in the left pane.
  3. Make sure that "Password protected sharing" is turned off.
share|improve this answer
    
Works like a charm! –  João Santana Dec 31 '12 at 10:49

I recommend for you to add a simple password in you Windows 7 system, a simple one just for you access the network in that case you can ask the system, both Ubuntu and XP, to memorize the password. I had the same problem; it's work very well for me.

share|improve this answer

You might need to check that "Turn off password protected sharing" is selected under Control Panel > All Control Panel Items > Network and Sharing Center.

You may also be able to give access to a Guest account on the Windows 7 box for the folders you want to share, and then from Ubuntu just enter the log-in name as Guest.

share|improve this answer
    
I have connected to Windows on password-protected share... Are you sure this is the problem? –  NoBugs Dec 29 '12 at 3:27

Make sure you add a user on the Windows 7 machine for the username on the Ubuntu machine. For example, if you want to connect to the Windows machine as "Fred" you need to add a "Fred" user to the Windows machine to assign permissions in Windows 7.

share|improve this answer
    
It's exactly what I do not want to do. I access the other Windows (XP) computer without having to create an user especifically to this; must have a way to do this with Windows 7. –  João Santana Dec 31 '12 at 10:10
    
Windows 7 has very different security features than XP. –  David Good Jan 1 '13 at 2:45
    
And yet uses the same network infrastructure. Besides, turning off password protected sharing resolved my question. Thank you to share your time, sincerely. –  João Santana Jan 3 '13 at 13:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.