Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I changed fstab and now Ubuntu (Precise Pangolin) does not start up. The screen goes blank and nothing happens.

I have a copy of fstab, but I don't know how to replace the current version with the backup, since the system does not star.

I've tried using the recovery mode, but when I choose "root" to go to the terminal a message specifies that the file system is in read only mode and I can't modify any files.

I've also tried mounting it again in read-write mode with:

mount -rw -o remount /

But when I do this, the terminal does not accept any other command (for every command I type, I always get the message "Denied permission").

Could you please help me fix this mess?

share|improve this question
If you have liveCD boot from it and try to replace your fstab file. – Milan Todorovic Dec 12 '12 at 20:12

I am assuming you only edited the fstab file and did a reboot. If this is true then:

  1. Start your PC with the LiveCD / LiveUSB. Wait until you get into the Live Desktop.

  2. Proceed to go to your hard drive and look for the /etc folder.

  3. Paste inside the /etc the backed up fstab file (Before any editing was done).

  4. After that reboot.

share|improve this answer
The issue was that I didn't have a Precise Pangolin CD. I tried with old CDs for Ubuntu 8.4 and 9.10, but neither of them worked! The solution that has finally worked for me was: 1. Choose the recovery mode option and press the key «e». 2. Search the «ro» (read only) option and change it to «rw» (read write). 3. Press F10. The recovery console appeared showing that it was in read-only mode, but it wasn't true! I have chosen the «root» and I have been able to replace the file using «sudo mv». Now the first task in line is to make a backup of the document folder! ¡Muchas gracias por todo! – user114344 Dec 12 '12 at 20:25
@user114344 - Add that to an answer, so it helps somebody else. No te preocupes y suerte. – Luis Alvarado Dec 12 '12 at 20:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.