Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed Ubuntu 12.10 on my Desktop but theirs no sound through the HDMI cable. I tried to set up the setting that comes with Ubuntu but still nothing. This is my motherboard ASUS F1A75-V PRO AMD any help would be great or advice. Thanks.

share|improve this question

Does not work on. you don't help people like this!

Ubuntu disable and hide digital audio output SPDIF in all Realtek / Nvidia Cards by default in fact it does same in all flavor of Ubuntu because no body cares the final user.

The prosedure to fixit is the same in all verssion of ubuntu and works for all sound cards Ati Nvidia Realtek Creative Bosse etc. You need to edit a file to do work get a terminal and tipe this

sintax: sudo nano /etc/modprobe.d/alsa-base.conf (enter)

then add this line to the end of the file

sintax: options snd-hda-intel model=auto (then use the end page controls to rewrite and save the file, then exit console)

At this time you need to reboot the machine, and then realize the missing digital audio spdif its work! go to task bar icon to select propper devise (its show now) to avoid get sound for all speackers at same time. if you need mute ubuntu alets or whatever you need to do enjoy.

for spanish take this link:

Boggart Akerley NASA Space Ship Program Sofware Engineer.

share|improve this answer

i have no sound also with 12.10. Sound Settings shows no entries in the 'Play Sound through' window. I tried adding your code (options snd-hda-intel model=auto) to modprobe.d and still the same. However, changing code to options snd-hda-intel model=generic brings up Dummy Output in the Play Sound through window but still no soundeven though have volume slider and can perform test. ! how do i get output to speakers to show?

soundcard is HDa Intel PCH ID 2805

also, Alsamixer only shows the PCM bar , nothing for main, Speakers etc

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.