Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Why don’t the Ubuntu repositories have the latest versions of software?

The latest release is 2.6.7. 2.4.8 is now considered legacy. Anything previous to those versions is considered "not supported" by Redis developers. Why is the Ubuntu Redis packaging lagging behind the current versions?

share|improve this question

marked as duplicate by fossfreedom Dec 12 '12 at 22:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

2 Answers 2

Redis is located in the Universe repository

From https://help.ubuntu.com/community/Repositories/Ubuntu

Universe - Community maintained software, i.e. not officially supported software.

Looking at packages.ubuntu.com, the version of redis-server in the 13.04 repositories is 2.6.0, which is pretty current, although could use a small update to 2.6.7. Since Universe is community supported, you might want to file a bug against the package here

From http://packages.ubuntu.com/search?keywords=redis-server&searchon=names&suite=all&section=all

lucid (misc): Persistent key-value database with network interface [universe]
2:1.2.0-1: amd64 i386
oneiric (misc): Persistent key-value database with network interface [universe] 
2:2.2.11-3: amd64 i386
precise (misc): Persistent key-value database with network interface [universe] 
2:2.2.12-1build1: amd64 i386
quantal (misc): Persistent key-value database with network interface [universe] 
2:2.4.15-1: amd64 i386
raring (misc): Persistent key-value database with network interface [universe] 
2:2.6.0-1: amd64 i386
share|improve this answer
3  
Actually, the package is simply synced over from Debian (as many Universe packages are). A bug report should be filed against the Debian package requesting a new version, and it should be linked in a Launchpad bug to request it be synced to Ubuntu once updated. –  dobey Dec 12 '12 at 19:26
add comment

I guess there are not so many people who are installing it via synaptics or similar. You can use a PPA for regular updates:

Examples:

https://launchpad.net/~rwky/+archive/redis

https://launchpad.net/~chris-lea/+archive/redis-server

You can also create a script that automatically downloads and compiles it for you or download and install it manually from the official web site.

Popular software gets more attention obviously so there are some packaged that are extremely old for the simple fact that not that many people download them OR the package maintainer just gave up. Some packages are just forgotten I guess and they don't even bother removing them.

PS: Just because something is not officially supported (even by the developer) doesn't necessarily mean that it is not used by some. There are plenty of examples out there. :)

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.