Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just bought a Matrox TripleHead2Go Digital Edition (T2G-D3D-IF) to drive my three widescreen monitors because the regular fglrx drivers were very sluggish when doing it directly from the video card (Radeon 6700). I installed the TripleHead2Go and everything works fine, but the ATI drivers see 3840x1024 as the max resolution:

Screen 0: minimum 320 x 200, current 3840 x 1024, maximum 3840 x 3840
DFP1 disconnected (normal left inverted right x axis y axis)
DFP2 disconnected (normal left inverted right x axis y axis)
DFP3 disconnected (normal left inverted right x axis y axis)
DFP4 connected 3840x1024+0+0 (normal left inverted right x axis y axis) 2352mm x 806mm
   3840x1024      60.0*+
   3072x768       60.0  
   1600x1200      60.0  
   1400x1050      60.0  
   2400x600       60.3  
   1280x1024      75.0     60.0  
   1440x900       60.0  
   1280x960       75.0     60.0  
   1280x768       75.0     60.0  
   1280x720       75.0     60.0  
   1920x480       59.9  
   1024x768       75.0     60.0  
   800x600        75.0     60.3  
   640x480        75.0     59.9  
CRT1 disconnected (normal left inverted right x axis y axis)

Reading this (https://wiki.ubuntu.com/X/Config/Resolution) I found you could add modes with xrandr, so I did:

$ cvt 5760 1080 60
# 5760x1080 59.99 Hz (CVT) hsync: 67.19 kHz; pclk: 519.25 MHz
Modeline "5760x1080_60.00"  519.25  5760 6128 6744 7728  1080 1083 1093 1120 -hsync +vsync

$ xrandr --newmode "5760x1080_60.00"  519.25  5760 6128 6744 7728  1080 1083 1093 1120 -hsync +vsync

This seems to work well.'

$ xrandr
Screen 0: minimum 320 x 200, current 3840 x 1024, maximum 3840 x 3840
DFP1 disconnected (normal left inverted right x axis y axis)
DFP2 disconnected (normal left inverted right x axis y axis)
DFP3 disconnected (normal left inverted right x axis y axis)
DFP4 connected 3840x1024+0+0 (normal left inverted right x axis y axis) 2352mm x 806mm
   3840x1024      60.0*+
   3072x768       60.0  
   1600x1200      60.0  
   1400x1050      60.0  
   2400x600       60.3  
   1280x1024      75.0     60.0  
   1440x900       60.0  
   1280x960       75.0     60.0  
   1280x768       75.0     60.0  
   1280x720       75.0     60.0  
   1920x480       59.9  
   1024x768       75.0     60.0  
   800x600        75.0     60.3  
   640x480        75.0     59.9  
CRT1 disconnected (normal left inverted right x axis y axis)
  5760x1080_60.00 (0xdb)  519.2MHz
        h: width  5760 start 6128 end 6744 total 7728 skew    0 clock   67.2KHz
        v: height 1080 start 1083 end 1093 total 1120           clock   60.0Hzw

It's now there, but it's not connected. So I tried connecting it to DFP4. This is where I hit a brick wall:

$ xrandr --addmode DFP4 "5760x1080_60.00"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  141 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  43
  Current serial number in output stream:  44

I verified that the product specs do support 5760x1080. What could be going wrong here? Have I added the mode incorrectly?

Thanks very much for any help you can offer.

Update: I tried this after reading another thread:

$ xrandr --fb 5760x1080
xrandr: screen cannot be larger than 3840x3840 (desired size 5760x1080)
share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.