Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

While trying to compile a program (pygobject), running ./configure I am told that I don't have glib. So, I download the tarball and compile and install, no problems. now when I try to ./configure the package again, I get the following error:

checking for GLIB - version >= 2.24.0... 
*** 'pkg-config --modversion glib-2.0' returned 2.34.2, but GLIB (2.34.0)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files 
no 
configure: error: maybe you want the pygobject-2-4 branch?

Here is the entire prompt: http://pastebin.com/raw.php?i=Gs6MrTWh

share|improve this question
    
Have you found solution for this issue. please let me know, i'm also stuck with issue. saravana –  saravana May 27 at 6:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.