Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have AMD Radeon 7470M 1GiB garphics card. I installed Ubuntu in the nomodeset, after my first boot, I just opened it from boot screen by pressing 'e' and replaced “quiet splash” with "nomodeset". It worked fine; I can log in but after that I installed AMD catalyst drivers for my graphics card. They are not working and even I opened the rc.local file as the root user 'sudo nano /etc/rc.local' copied and pasted the following lines just before the line exit 0 :

1) chown -R $USER:$USER /sys/kernel/debug
2) echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

it doesn't work for me. Every time which I boot to OS I need to replace "quite splash" with "nomodeset" by pressing 'e' in the boot screen; only then can I log in to Ubuntu.

How can I fix this? It's very difficult to replace that thing every time.

Thank you

share|improve this question

1 Answer 1

up vote 0 down vote accepted

How to permanently set kernel boot option nomodeset on an installed OS (not wubi)

  1. Open a terminal by pressing Ctrl+Alt+T and enter:

gksudo gedit /etc/default/grub

Or if that does not work (as mentioned in the comments)

sudo gedit /etc/default/grub
  1. Enter your password when prompted, and the file `grub' will open in gedit.

  2. Look for the line:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Save the file and exit.

At the command prompt enter:

sudo update-grub

This will update Grub's config with the new settings permanently.

share|improve this answer
    
Thanks for your response, But Unable to open the file grub it showing error: (gksudo:2588): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap", –  Viswanath Sai Dec 14 '12 at 3:45
1  
Try sudo gedit /etc/default/grub. I don't know why gksudo is not working. –  user68186 Dec 14 '12 at 4:19
    
Thanks it works fine now ...... –  Viswanath Sai Dec 14 '12 at 13:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.