Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was trying to run a linux binary from this site:

http://www.robots.ox.ac.uk/~vgg/research/affine/descriptors.html#binaries

specifically, the "compute_descriptors.ln"

However, the terminal only responded with command not found. The extension also looks very uncommon.

I am running Ubuntu 12.10.

share|improve this question
1  
what command did you type? could you copy/paste the exact command and the exact repsonse? –  Nanne Dec 12 '12 at 10:50
    
I downloaded the .gz file, extract it. then type "compute_descriptors.ln" in a terminal as indicated in the webpage mentioned. –  nschong Dec 12 '12 at 10:53
    
I did change my path correctly –  nschong Dec 12 '12 at 10:54
    
Sorry, just noticed typo in my question. the responds was "command not found" –  nschong Dec 12 '12 at 10:56
add comment

2 Answers

up vote 1 down vote accepted

You probably typed

$ compute_descriptors.ln

but you need to do

$ ./compute_descriptors.ln

(notice the leading ./, that is also mentioned on the site you linked)
The command isn't known "globally" (in your path) so you must specify that the command is in fact in this directory.

You could also need to do a chmod +x, but i'd just try the ./ prepending first.

share|improve this answer
    
hi, thanks. actually, I made both mistakes. Just another questions: how do we add a folder to the "globally" known path. I assume that it is similar to the PATH environment variable in Windows? –  nschong Dec 12 '12 at 11:34
    
You can set your path environment like you can read here: askubuntu.com/questions/170222/how-do-i-set-a-path-permanently . –  Nanne Dec 12 '12 at 12:24
add comment

I think you missed some steps (chmod +x maybe?). Works for me:

$ wget http://www.robots.ox.ac.uk/[...]/compute_descriptors.ln.gz                
[...]
2012-12-12 11:55:36 (1.55 MB/s) - `compute_descriptors.ln.gz' saved [3222607/3222607]                                            

$ gunzip compute_descriptors.ln.gz                                                                             
$ chmod +x compute_descriptors.ln 
$ ./compute_descriptors.ln 
Interest point descriptors implemented by Krystian.Mikolajczyk@inrialpes.fr                                                      
at INRIA Rhone-Alpes.[ref. www.inrialpes.fr/movi/people/Mikolajczyk/Affine]                                                      
Options:
[...]
share|improve this answer
    
oh thanks a lot. –  nschong Dec 12 '12 at 11:01
    
just another questions, how did you notice it? I'm new to linux, –  nschong Dec 12 '12 at 11:02
    
@soon This is basic file system permission and Bash. You would have run into the same with a basic script and trying to execute it. –  gertvdijk Dec 12 '12 at 11:30
    
i see, thanks a lot for the tips –  nschong Dec 12 '12 at 11:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.