Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu 32 bit 12.04 server edition but i am having issues with apt-get updating.

The server is able to ping the outside world (both 8.8.8.8 and www.google.com) but when I attempt to sudo apt-get update the first bit works but then I get this:

enter image description here

If i attempt to check or autoclean with:

sudo apt-get check

I get this:

enter image description here

I have tried the fix detailed here:

How do I fix a "Problem with MergeList" error when trying to do an update?

But it does not work, the same thing occurs again. Any suggestions?

PS. The server is a fresh install, no external programs have been added.

EDIT: We have tried using different sources, both aarnet and au.archive sources were tried.

share|improve this question
    
choosing different sources caused this problem. –  K.K Patel Dec 13 '12 at 4:11
    
@K.KPatel Unfortunately not, we used the original source and tried several others as well, the actual answer is the one i have posted below. –  Ben Dec 13 '12 at 4:14

2 Answers 2

Try using another mirror. I assume you have Internet connectivity. Open Ubuntu Software Center | Edit | Software Sources and change "Download from" to something else. Then in a terminal run "sudo apt-get update".

share|improve this answer
    
where can i find different mirrors? –  Ben Dec 12 '12 at 22:27
    
We have tried, As now noted in the question, any other suggestions? –  Ben Dec 13 '12 at 0:44

So the answer is:

Watch out for university networks. It required a log in form a web browser to enable that machine to access certain parts of the Internet. To get around it we had to log into the university network using a live usb version of ubuntu desktop. Then the update went through just fine.

Damn networks !!

share|improve this answer
    
Why did you log in from the live CD instead of from the installed system? –  jdthood Dec 13 '12 at 4:45
    
@jdthood there is no browser on ubuntu server, not sure how you can access the login page from cmd prompt. So we used the live CD for the ubuntu desktop version. –  Ben Dec 13 '12 at 5:04
    
Well, you could use lynx. I just asked because I wanted to know if you had run into some technical problem connecting to the login page from the installed system. –  jdthood Dec 13 '12 at 5:14
    
How would i use lynx to connect to a website, be redirected to the university log in page and then enter password and username information? Do you want to add that as an answer and i will upvote and mark as correct –  Ben Dec 13 '12 at 5:18
    
Hmm, well on second thought you couldn't use lynx since it's not installed by default, and your problem was that you couldn't connect to repository servers. :) –  jdthood Dec 13 '12 at 5:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.