Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Unbuntu 10.04 installed from Windows 7 (Wubi filesystme), Now Ubuntu is not booting giving this error.

Target filesystem doesn't have /sbin/init.
No init fount. Try passing init= bootarg.

BusyBox v1.13.3 (Ubuntu 1:1.13.3-1ubuntu7) built in shell (ash)
Enter 'help' for a list of build in commands


I looked at the suggestions here.That can't solved my problem because Ubuntu is installed from Windows and all the drive shows of Windows. How can I get this to boot?

share|improve this question
Was it running fine before or did it happen right after you installed? If it was running fine before, was there some event that preceded this? – bcbc Dec 12 '12 at 0:10

I found the following instructions from here under the section "How can I access my Wubi install and repair my install if it won't boot?"

It worked for me with little changes as below:

  1. Boot using Ubuntu live USB/CD

  2. Go in System -> Administration -> "Disk Utility" (For 10.04, for other Ubuntu version somehow reach to "Disk Utility")

    Make sure your partitions where Wubi created the root.disk file is mounded. If not, you have to mount it with the "Mount Volume" button.

  3. You should see the root.disk here -


    (Note: In your case the name can be different for "host")

  4. Perform file system check on this file as below:

    sudo fsck /host/ubuntu/disks/root.disk

    It corrects the corruption using the above command

  5. Reboot the machine

  6. Enjoy your Ubuntu

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.