Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, I don't know what exactly how I managed to delete the MBR record on windows partition. But let me explain what I did next, I ran the ubuntu boot repair tool and now Windows is not even listed in my grub loader.

So I went and booted with windows cd and choose repair. Then I ran ubuntu boot repair again via live cd. Here is the log http://paste.ubuntu.com/1426181/. Still no luck.

Looks like osprobe can't detect windows on my /dev/sda2 partition. Any clues ?

Here is how my partitions look like:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x525400d1

Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   509620669   254706911    7  HPFS/NTFS/exFAT
/dev/sda3       509622270   976773119   233575425    5  Extended
/dev/sda5       509622272   957757439   224067584   83  Linux
/dev/sda6       957759488   976773119     9506816   82  Linux swap / Solaris
share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Sounds like there's a good chance something is broken with Windows which is causing Ubuntu not to recognise it properly. Try following the instructions here to fix Windows and then here afterwards to reinstall Grub.

share|improve this answer
    
Thank you for your answer. I got it working now. The problem was that I didn't go through windows repair correctly. Did a windows repair again and didn't even have to do the grub reinstall, since I already manually added the windows partition to my grub settings. –  Simon Polak Dec 14 '12 at 3:02
    
Forgot to mention, I also put the boot flag on the sda2 partition using gparted. –  Simon Polak Dec 14 '12 at 3:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.