Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to make my Canon pixma MP540 work under Ubuntu 12.10. I have installed SANE using their install instructions file.

Now, I did sudo sane-find-scanner and it found no devices. I started making this question but I decided to try scanimage anyway, and it listed my scanner as an available device! It all worked perfectly (though I haven't tried any options, which SANE lists nicely too by the way).

How come sane-find-scanner doesn't find it, while it works?

The man sane-usb page told something about usbfs and usblib. It told to add a line to /etc/fstab for an usbfs entry, or an usbdevfs entry if that didn't work, but neither worked so I thought I was going to have a lot of difficulties.

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.