Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My first question!

I'm not able to get my internal mic to work properly. All I can hear is a lot of static and noise, plus barely my voice.

If I boost the sound static/noise volumes up as well.

My laptop is an ASUS F5-SL with a HDA SIS966 (ALC660-VD Analog) in Kubuntu 12.04 (64 bits).

I tried mixing volumes with alsamixer and installing alsa-hda-dkms with no success.

share|improve this question

try to run your program with pulseaudio suspended - like this:

pasuspender -- yourprogram

and record a sample.

If it works better, it might be a problem related to the pulseaudio-alsa communication.

share|improve this answer

Well you see it may be the laptop have you got warranty on the laptop?

Or just follow the steps below:

1) Open the “Volume Control” panel. 2) In the “Volume Control” panel: “Edit” → “Preferences”. 3) In the “Volume Control Preferences” panel: tick 'Microphone' and 'Microphone Capture', and 'Capture'. 4) Close the “Volume Control Preferences” panel. 5) In the “Volume Control” panel, “Playback” tab: unmute the microphone. 6) In the “Volume Control” panel, “Recording” tab: enable audio recording from capture.


share|improve this answer
o_O My internal mic works flawlessly under windows. It never did under GNU/Linux, however. Actually, I think a lot of people don't get mics to work under linux. My laptop is around five years old and my mic never worked with any single distribution I tried, afaik. It didn't really bother me much as I don't really use it but since Steam is going to happen I'd like to speak with my friends as I play games (with teamspeak, for example). Or use voice chat in my laptop (I use my phone for that usually). For the matter, an external mic doesn't work properly either. – simongaiteiro Dec 11 '12 at 19:46
Ok ill edit my answer but could you tick it and vote if it worked please? – Wojciech Wojtanowski Dec 12 '12 at 19:01
I use KDE. I believe you're telling to go to some sort of Gnome/Unity control panel. Anyways, I can record sound. Just not properly due to heavy static/noise. Is there a way to reduce those? – simongaiteiro Dec 12 '12 at 20:25
Oh no you cant thats the problem you see either its your computer fan or the mic it self! There is a really professional solution for this but its too technical for me :D – Wojciech Wojtanowski Dec 13 '12 at 16:40
Well. The mic works well on windows... :-( – simongaiteiro Dec 13 '12 at 17:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.