Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried re-installing it but it simply kept giving me this error in a little window

it also gives me an identical error some 3 seconds later without any new provocation.

share|improve this question
add comment

4 Answers 4

Make sure steam isn't running at all in ~/.steam/.

  1. Delete ~/.steam/steam.pid

  2. Edit ~/.steam/registry.vdf line 29 from "Offline" "1" to "Offline" "0"

Source

share|improve this answer
    
In my case, "Offline" was already set to "0" but Steam kept starting in Offline mode. Luckily, step 1 was enough to fix the issue. –  Hubro Jul 21 '13 at 22:23
add comment

This solved it for me

sudo apt-get install xfonts-75dpi xfonts-100dpi

Try it! if first time dont work, restart!

share|improve this answer
    
a combination of this and deleting ~/.steam/steam.pid did the trick for me. Also, ~/.steam/registry.vdf didn't exist –  jairo Jan 11 at 3:40
add comment

In my case there was not enough space on the disk. At least 250MB are required. After freeing space, the install process started correctly.

share|improve this answer
add comment
  1. Delete ~/.steam/steam.pid
  2. cat > ~/.steam/registry.vdf
  3. "Offline" "0" ^C
  4. If error restart steam =)
share|improve this answer
    
Don't steal answers. –  zeokila Mar 4 at 20:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.