Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a package that depends on an old version of tornado:

[DEFAULT]
Package: tonythepony
Depends: python-tornado (<= 1.3), python-git

There is a repository that provides python-tornado=1.2.1-1, none the less, I get this error message:

The following packages have unmet dependencies:
 tonythepony : Depends: python-tornado (<= 1.3) but 2.1.0-2ubuntu0.1 is to be installed
E: Unable to correct problems, you have held broken packages.

So, in order to install the package, I have to run this:

sudo apt-get install python-tornado=1.2.1-1
sudo apt-get install tonythepony

Is there any way to make it so that tonythepony just fetches and installs the older version? (again: I have my own repository, which provides the older version)

share|improve this question
    
I'm assuming in the second paste block, you installed it with dpkg? dpkg doesn't grab dependencies, it just installs the local deb files you give it. –  tumbleweed Dec 12 '12 at 14:51
    
I'm actually just using apt-get here (and gdebifor local testing) –  Stefano Palazzo Dec 12 '12 at 17:49
    
Did you see the "you have held broken packages"? –  tumbleweed Dec 12 '12 at 22:07
    
Pretty sure it refers to the package being installed at the moment. I've been trying this out on fresh VMs. –  Stefano Palazzo Dec 13 '12 at 13:05
    
so, you've checked to see that nothing is held? I don't know what gdebi does under the hood... –  tumbleweed Dec 13 '12 at 14:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.