Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did use Ubuntu 10.10 for a long time, and now I replaced it with Ubuntu 12.10, every thing works great, but I do have one little problem, which is with my wireless card.

On Ubuntu 10.10, it worked PERFECTLY, and it even worked better than in windows 7, so I was very happy with Ubuntu 10.10, but, like I said, after installing 12.10, my wireless card doesn't work any more, so I heard that KERNELS are the reason for that.

Are kernels the reason for my wireless not working now? If yes then please teach me how to remove my current kernels and install 10.10 kernels.


I went to -Additional Drivers- and i found something very weird i took picture and this is what it look like

enter image description here

"apply changes" Button NOT active so i can't install driver :(

anyway... my Wireless card is WL-138g v2 (remember on Ubuntu 10.10 it was WORKING 100% normally and FREE i did NOT pay for it driver)

so... now what shall i do ? it is saying in picture // Using Non-Free firmware for linux kernel drivers from linux-firmware-nonfree (proprietary) //

BTW i did "rfkill list" but NO-thing appear under that command.

share|improve this question
    
This appears to be an annoying PITA Broadcom b43 wireless card. It's kinda hard to get it to work, and it wasn't working in 10.10 by default - you must have taken actions your own. Share the whole story please. Please post the output of dmesg | grep b43 and ls -al /lib/firmware/b43 and the Device vendor/product ids: lsusb for USB, lspci -nn for PCI. –  gertvdijk Dec 15 '12 at 12:54

2 Answers 2

It looks like it is missing kernel modules for your wireless card. It is though not a reason to downgrade to older kernels.

Try using the 'Additional Drivers' software (used to be installed by default earlier) to search for a suitable driver. It will do the rest of the job for you.

It may also be useful to make sure it is not blocked by the system or hardware switch. To check this, execute:

rfkill list

To remove of Software lock, execute:

rfkill unblock <device>

share|improve this answer
    
@user80547, did this solve your problem? please, let us know. –  Pavel A Dec 12 '12 at 18:59
    
uhhh... i found solution for my problem it's very simple i just did : sudo apt-get install firmware-b43-installer THIS FIX MY PROBLEM –  user103533 Dec 15 '12 at 20:48

uhhh... i found solution for my problem it's very simple i just did: sudo apt-get install firmware-b43-installer ---THIS FIX MY PROBLEM---

BUT dont forget to REBOOT machine, you have to restart you computer after boot in you see wireless work normally. anyway... thank you guys for help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.