Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 12.04 on an Acer 3690 and everything works perfectly except for the wireless internet. It says "Firmware Missing". I've already done the additional drivers thing, and that didn't help. Any suggestions? I'm new to ubuntu, so make them easy to understand :) Thanks!

share|improve this question
    
Where do you get the Firmware Missing message. Also, which wireless adapter are you using? –  Karthik Dec 11 '12 at 4:01
    
In the network settings, under wireless is where it says firmware missing. I'm just using the built in wireless card in the Acer Aspire 3690 –  scott Dec 11 '12 at 4:09

1 Answer 1

I am not sure if this will solve your problem, but no harm in trying right?

I had a similar problem in my Acer laptop. I think the new kernel and broadcom drivers are the connection. I ran

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

and it worked for me on my Acer Laptop.

Refer Ubuntu 12.10, Wireless not working for more details.

share|improve this answer
    
I feel stupid asking this, but is that all one code to all be ran at the same time? –  scott Dec 11 '12 at 4:18
    
Refer to askubuntu.com/a/227403/67346 for a more simpler explanation –  Karthik Dec 11 '12 at 4:27
    
After I followed those directions, in the network settings "wired" and "wireless" have disappeared.My only option is proxy. And it also won't read the Ethernet cable now, what do I do? –  scott Dec 11 '12 at 4:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.