Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just want to install VLC latest from 12.04 LTS to 10.04 LTS How to do it?

share|improve this question
    
Do you mean to say that you want the latest version of VLC available in 10.04 Repos, but your Ubuntu on the whole 12.04 –  Hashken Dec 11 '12 at 1:33
    
I would like to get any way VLC. It would be ok if its possible with LTS fixes from LTS version. So it doesnt matter for me but for this question an VLC could be an example for other packages also if other people want some other package from newer Release. I did many trys and none really works. Im out of creative ideas. Now needed some more technical solution. –  Kangarooo Dec 11 '12 at 1:46
    
So you are using Ubuntu 10.04, but want the VLC version available in 12.04 –  Hashken Dec 11 '12 at 1:51
    
Yes Yes Yes Yes Yes :) In my Ubuntu LTS 10.04 from LTS 12.04 –  Kangarooo Dec 11 '12 at 1:52

2 Answers 2

One of the methods of installing a software not in the standard ubuntu repos but through apt-get is by using a Personal Package Archive (ppa). All ppa's are hosted on http://launchpad.net. On searching, i found that one of the ppa has the version of vlc that you require (vlc-2.0.4 ). https://launchpad.net/~n-muench/+archive/vlc.

This has all the dependencies vlc-2.0.4 needs.

Add this ppa to your system like so:

sudo add-apt-repository ppa:n-muench/vlc2

Then update your sources by:

sudo apt-get update

Then install again:

sudo apt-get install vlc

That should do it. I tried and it works. You can install from other ppa as well but make sure it builds successfully by checking in the right hand side of the ppa's main page.

share|improve this answer
    
To back it up, on some googling i found that there is a blog post which describes what you want, should have jus redirected you there, tuxtree.com/2012/02/… –  c0redumP Dec 11 '12 at 19:09
    
I tryd that already. Didnt help. Since im on Lucid and i added it then it adds that its Lucid. Since we see on launchpad.net/~n-muench/+archive/vlc2 he doesnt have ppa for lucid. So i tryd changing in Software Sources name Lucid to Precise and that doesnt help either. See what happens if i change to Precise this ppa paste.ubuntu.com/1426023 –  Kangarooo Dec 11 '12 at 20:04
    
Are u interested in 2.0.4 in particular or any version 2.0+ ? –  c0redumP Dec 11 '12 at 20:39
    
Short: Latest is ok. Also ok from LTS could be ok. Witch is now 2.0.3. Long: I wanted to use VLC instead of Flash in Firefox. Since i couldnt get any greasemonkey script to work and no support from their developers then ill use method described in askubuntu.com/a/169410/9550 its using addons witch open YT link in VLC. Since VLC of 10.04 doesnt open YT links as it has been in previous versions and then fixed in them so now its fixed in latest VLC or in later version with Youtube addon witch doesnt work in 10.04 version. So step obtaining VLC is braking from testing VLC youtube support. –  Kangarooo Dec 12 '12 at 4:38
    
The lucid-bleed experimental ppa has a backport of vlc-2.0.1 against vlc-2.0.3 in 12.04 LTS. But im not sure if vlc-2.0.1 has YT support. You can give it a try though. launchpad.net/~lucid-bleed/+archive/lucidbleed-exp –  c0redumP Dec 12 '12 at 5:04

As of today, the latest version of VLC available now is 2.0.4, which is the same one available in Ubuntu 12.10, so if you upgrade to Ubuntu 12.10, you will have the latest version of VLC


Since you are in 10.04 release, the VLC version you can get from Synaptic is only the one in 10.04 repos.

If you want a more recent version of VLC, you can get the .deb package from the this website.

But the problem is that the dependencies of the latest VLC version may not be present in your current 10.04 repos. In that case, you would have to go manually install them and then their dependences and so on.

This defeats the purpose of having a package management system.

So, if you want to use a latest version of VLC (say available in 12.04 repos), I suggest you upgrade your system to 12.04.

share|improve this answer
    
Yes i know latest i can get normally is witch i have in my 10.04 repos but I want latest. Latest cant be found on vlc website. So maybe from LTS 12.04 somehow is possible AND find that out im asking this question. –  Kangarooo Dec 11 '12 at 2:10
    
The latest version of VLC available now is 2.0.4, which is the same one available in Ubuntu 12.10, so if you upgrade to Ubuntu 12.10, you will have the latest version of VLC –  Hashken Dec 11 '12 at 2:14
    
Yes everyone know that. 12.10 btw isnt LTS so not so good for long time use. So better would be updating to LTS. BUT Unity versions are slow witch is reason im staying on 10.04. People still could want to have solution to this question- how to get latest safe LTS version of programm without upgrading release. –  Kangarooo Dec 11 '12 at 2:23
    
As long as the program does not have any dependencies you can just get the package of the latest version and install it directly. I have tried this. Why don't you just go the download site mentioned in the answer and just try installing the latest VLC available there. If does not give any errors, then well and good. If it does give errors please post the errors here. –  Hashken Dec 11 '12 at 2:28
    
What do you mean by that? There is package? Where? If you can back up what you say then only write. I did all what you wrote long time ago befor i posted this question and searched a lot. You mentioned deb package once already but didnt gave info where it is. Now you say theres package and you cant find it yourself. Then why you write me to get something what doesnt exist? –  Kangarooo Dec 11 '12 at 4:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.