Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't seem to get a straight answer on this. I would like to add a 3rd display onto my laptop + external monitor setup. While my current setup (Thinkpad X201) has an open VGA port (am using the laptop's display + displayport with external monitor) it appears that I can't drive 3 monitors natively.

I would like to explore what my alternatives are to get another display into the mix. I've found lots of references to displaylink but nothing absolutely confirmed to work.

share|improve this question
    
If it (displaylink) "just works" on BSD, I can't imagine that it wouldn't work on Ubuntu...just a thought. I wonder about this too. –  hbdgaf Jan 22 '11 at 21:37
add comment

1 Answer

A user reports it working on Ubuntu 9.04 after compiling some packages: http://mulchman.org/blog/?tag=displaylink

edit: apt-cache search displaylink returns xserver-xorg-video-displaylink - X driver for DisplayLink devices...it wouldn't be included if it didn't work. It might not support ALL resolutions, but I think it more than satisfies will it work.

edit: I would try pasting this section into you xorg configuration:

Section "Device"
Identifier "DisplayLinkDevice"
driver "displaylink"
Option "fbdev" "/dev/fb1"
EndSection

Section "Monitor"
Identifier "DisplayLinkMonitor"
EndSection

Section "Screen"
Identifier "DisplayLinkScreen"
Device "DisplayLinkDevice"
Monitor "DisplayLinkMonitor"
SubSection "Display"
Depth 16
Modes "1280x1024"
EndSubSection
EndSection

Even with the windows drivers not all resolutions are supported across all chipsets.

another point worth noting is that in some configurations it has been noted that the DVI dongle doesn't function appropriately

okay maybe i found it: http://lists.freedesktop.org/archives/libdlo/2010-November/000807.html


The most interesting thing is that I found out why I can use the
displaylink driver together with nvidia but not the fbdev driver.

This is just an explicit check (xf86Bus.c, xf86PostProbe()) whether both
framebuffer and pci devices have been claimed, if so the server refuses
to start.
The displaylink driver just clears the corresponding fbSlotClaimed flag,
no more magic required. But, there is another (similar) check in
xf86ClaimFbSlot() (xf86fbBus.c) that, when claiming a frambuffer slot,
makes sure no PCI slot has been allocated, I guess thats the reason why
the displaylink driven device must be registered first (as primary screen).

On another thread the green screen problem is attributed to using DirectFB

discussion here: http://web.archiveorange.com/archive/v/BNQl8iH957oQe619QVek
they indicate that it worked, if slowly. but the box in question was a 266MHz monster so...

share|improve this answer
    
Mulchman's last notes on this are 1 1/2 years old, and not specific to 10.10... am hoping to find newer information regarding what absolutely will work. –  Kendor Jan 23 '11 at 14:45
1  
I went ahead and bought a Diamond DisplayLink based device and followed the instructions here: ubuntuforums.org/showthread.php?t=1493143 on how to get it recognized. Suffice to say, it didn't just work out of the box (I had low expectations). If you are here and have gotten this working, am wondering if you can share how you did it... my troubles are documented here ubuntuforums.org/showpost.php?p=10399794&postcount=23 –  Kendor Jan 26 '11 at 21:46
    
also @Kendor , if you ultimately wind up not getting it working and are frustrated let me know. I'll buy the adapter off of you and do the testing on my end to get it working. Ultimately I think it should. –  hbdgaf Jan 26 '11 at 22:15
    
@aking1012 I modified xorg per your suggestion, and tried with various combinations (my monitor is 1440x900), but also tried 640x480 8-bit as a safety.. those changes didn't work. I also tried changing to fb0 from fb1 (not sure how to tell the difference).... No dice on the above. I also had a second dongle, so tried that too... also didn't work. If it were to light up, how does one control it? would this show up in the normal "Monitor Preference" app? –  Kendor Jan 27 '11 at 20:00
    
It should. But then, it should also just work...If you're getting the green screen the device is kind of functioning, just not appropriately. I would look at refresh rates and resolutions. The first entry (the real video card) should be frame buffer 0. The usb should be frame buffer 1. If the device were not functioning at all it would be giving you the same thing you get with the usb not connected at all(at least this is what it did for me when i had to set one up about 6 months ago). Just a black screen. Green is progress...almost there. –  hbdgaf Jan 27 '11 at 20:20
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.