Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have HD 4850 card, Ubuntu 12.10 and installed legacy drivers using makson96 ppa. The issue is, that FGLRX can not detect my device and loads vesa bios. I had the same problem on ubuntu 11.10, 12.04 versions. I want to manually help fglrx find a matching device to load as it shoudld do.

It is interesting, why does fglrx search for a device in a PCI:0@1:0:1 Bus? in xorg.cof different bus is indicated:

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection


fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 4800 Series         
OpenGL version string: 3.3.11653 Compatibility Profile Context

Here is a part of my xorg log:

[     3.846] (II) VESA: driver for VESA chipsets: vesa
[     3.846] (II) FBDEV: driver for framebuffer: fbdev
[     3.846] (++) using VT number 7

[     3.846] (WW) Falling back to old probe method for fglrx
[     3.883] (II) Loading PCS database from /etc/ati/amdpcsdb
[     3.883] (--) Assigning device section with no busID to primary device
[     3.883] (--) Chipset Supported AMD Graphics Processor (0x9442) found
[     3.884] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
[     3.884] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[     3.884] (II) AMD Video driver is signed
[     3.884] (II) fglrx(0): pEnt->device->identifier=0xb7791d8f
[     3.884] (WW) Falling back to old probe method for vesa
[     3.884] (WW) Falling back to old probe method for fbdev

from lispci i foud out finally, that my video card is in 01:00.0 slot. logically, if fglrx searches for a vdeo card device in a wrong place, it will not find it.

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV770 [Radeon HD 4850]

The log also says:

(WW) fglrx(0): board is an unknown third party board, chipset is supported Thanks in advance.

share|improve this question
    
I am a novice user. Through i had research on this problem, could not find a solution. I tried a nomodeset mode, reinstalled drivers numerous of times from many tutorials, have tried ubuntu 11.10 and 12.04, i have downgraded bootloader, but still fiasco. –  Lejo Dec 10 '12 at 22:50
    
See askubuntu.com/questions/176760/… –  user68186 Dec 11 '12 at 17:15

2 Answers 2

I'm working on the identical problem in Debian, will post back here when I've got it sorted.

See: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=712528

What version of the fglrx driver are you using? As pointed out in the comments, the regular Catalyst driver does not support the 4800 series cards. There may be a "legacy" version that supports it (as there is in Debian) but I could not tell from http://packages.ubuntu.com/raring/fglrx.

share|improve this answer

I had the exact same card, 4850 and I found that fglrx even when configured properly takes up too much resources for the card. The best performance is shown when using the opensource driver. Do
sudo amdconfig --uninstall
and stick to the opensource driver is my suggestion as a user of that card for 3 years on Linux

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.