Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have installed 12.04 on a dell vostro 2520 (previously 11.10) and wifi is gone now but wired network remains. I've reviewed the other questions and tried this one:

and some stuff but no luck yet. The following is the process so far so hopefully someone can help.

I have the Broadcom bcm43142 chip.

I have made sure in the bios that the wlan is turned on, and it appears the laptop does not have a wireless hardware switch, only the keyboard function shortcut which turns bluetooth on and off on the taskbar but there is no lightup of the wireless function on the laptop itself.

Dell does not appear to have any drivers for ubuntu and google does not appear to be much help :( Perhaps someone can please provide the recovery disk ISO that originally came on the hard drive?

Thanks in advance! .

share|improve this question

marked as duplicate by Eliah Kagan, hhlp, con-f-use, Mik, RolandiXor Mar 19 '13 at 17:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer 1

Your problem looks similar to mine, and I think the new kernel and broadcom drivers are the connection. I ran

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

and it worked for me on my Acer Laptop.

Refer Ubuntu 12.10, Wireless not working for more details.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.