Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I was meant to run

add-apt-repository ppa:pitti/postgresql
apt-get update
apt-get install postgresql libpq-dev

but instead I ran without the previous two commands

apt-get install postgresql libpq-dev

which I then followed with:

apt-get --purge remove postgres
apt-get auto-remove

and tried to start back up properly from the first step however, my machine is still installing postgres 8.4 instead of 9.2.

How can I get it to stop doing that?

Edit: I see that the package is not being fetched...

W: Failed to fetch  404  Not Found

May be a server error that just happens to be live the first time I try to install it.

Edit 2: Turns out that it is using "pitt" instead of "pitta" for some reason...will completely restart. ARGHH.

Edit 3: pitti not pitta

share|improve this question
Just commenting, it is pitti not pitt or pitta and the package name is postgresql-9.2 not just postgresql. – Uri Herrera Dec 10 '12 at 18:46
up vote 1 down vote accepted

The package you are searching for is postgresql-9.2 not potgresql according to the ppa you are using.

sudo add-apt-repository ppa:pitti/postgresql
sudo apt-get update
sudo apt-get install postgresql-9.2 libpq-dev
share|improve this answer
how can you tell? I was following the railscasts on the subject and they just used postgresql not postgresql-9.2? that would be very handy information... – ovatsug25 Dec 10 '12 at 19:12
He probably just looked at Pitti's launchpad account. – Brandon Bertelsen Dec 10 '12 at 23:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.