Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Time zone is GMT and the time is set to 5 hours before this every time I reboot (American time?)

Ubuntu 11.04 64b Dual boot with Win7 ASUS M4A78LT-M

share|improve this question
    
Does this happen on Ubuntu 10.10 as well? –  8128 Jan 22 '11 at 14:50
    
I used to have very similar problem when I used to double-boot. I guess the point is that windows sets BIOS's clock to UTC, while ubuntu prefers the local time (or something like that). However, I've never managed to fix it - but anyway I can confirm this issue. –  Rafał Cieślak Jan 23 '11 at 19:57

4 Answers 4

up vote 2 down vote accepted

Make sure it has the correct location in System->Administration->Time and Date. All thought you may have selected UK in location options in the installer, you have to set clock location from America to Britain

share|improve this answer

when you installed ubuntu you set it to UTC time. seriously, ive made the mistake. always 7 hrs difference between computer time and bios time. its in ubuntu time and date settings.

share|improve this answer

Could your BIOS be wrong, Has your computer shown "CMOS Bad" error? It may be time to replace your battery or change your settings!

share|improve this answer
    
Wouldn't it set the year to 2007 or something rather than 5 hours less than the current time? –  tm1rbrt Jan 22 '11 at 17:38

I have seen this on Acer eee notebook 2 weeks ago ive put wubi netbook ubuntu version for one friend and its time was always reseting to gmt +1 but needed is gmt +2 location was set but still maybe windows 7 reseting somehow.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.