Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My university uses a VPN system for internet connections. A couple of days ago I installed 12.04 on my computer and set up the VPN following a guide specific to linux here. It would work quite well, but disconnect every now and then, especially when I checked for new updates. After a few reconnections however, it would become stable until I powered down the computer.

On upgrading to 12.10 , the VPN would connect and then fail instantly whenever any network activity was attempted (checking for updates, loading a web page etc). I have now reverted back to 12.04 with a fresh install.

So I guess what I'm asking for is a bit of help as to what I should do next. Reinstall 12.10 and see if the issue disappears? Visit the university's IT helpdesk? My VPN settings are exactly the same as on their guide.

The VPN worked flawlessly with Windows installed. The computer is a HP dc7100 SFF.

Any help would be much appreciated

Thanks in advance

Oli

share|improve this question

2 Answers 2

If you have any connectivity at all then your VPN settings are probably correct. That the connection falls away and that the problem got worse on upgrade to 12.10 support the hypothesis that the problem is with the network driver. Do you have another interface (Wi-Fi or Ethernet) which you are not using to connect to the Internet? Try connecting to the Internet only through that other interface and then connecting to the VPN. Does this solve the problem? If so then please file a bug report against the "linux" package at bugs.launchpad.net, describing your symptoms and mentioning the hardware and driver involved.

share|improve this answer
    
I don't have any other interface to connect through I'm afraid, just the Ethernet. –  oli Dec 10 '12 at 21:58

I see the university instructions are a wee bit old. With 12.10 I have found that I get best results with "Allow Stateful Encryption" enabled, especially if the authenticating server is an MS Windows server.

share|improve this answer
    
Thanks for the tip, I'll enable it and see if my connection improves –  oli Dec 10 '12 at 21:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.