Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm on Ubuntu 12.04 LTS using Unity. When I go to Dash home (either by clicking the icon or pressing the "Windows" key), and try to run rdesktop, it doesn't work - it either:

  • It either says "Sorry, there is nothing that matches your search" and does nothing, or

  • Opens a new Firefox window on a blank page.

rdesktop works fine from the command-line, and I think it used to work OK from Dash as well, but I couldn't swear to that.

Does anybody have any idea what's happening here?


John G

share|improve this question

When I upgraded to 12.04 I found that there were problems running rdesktop, especially as I was trying to use shared clipboard via RDP, so I tried the current remote desktop package called remmina and have found it to be excellent. The main problem with this option is that it doesn't import all your previously saved rdesktop connections, but they are human-readable if you open the hidden .rdesktop folder in your profile folder.

As for rdesktop working from a command line, did you fresh install U12 or was it an upgrade from 11.10? If new, you must have installed rdesktop manually, in which case the dash ought to work, or if you copied it as an executable then the system won't put it in the dash. Run the Synaptic Package Manager (if a new installation of U12 you need to install it: sudo apt-get install synaptic). If installed properly, rdesktop will have a green box next to it.

Remmina has the added advantage of sharing a local folder via RDP which shows up on the remote MS Windows machine as an extra drive. It's a good way to transfer files to and from the remote machine. Remmina also allows you to easily scale the remote desktop window, even in VNC. This helps me to manage customers' computers from my tiny netbook.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.