Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 64bit.

I tried to install WINE in 11.10 but met with some difficulties because of which I removed it. I tried to install Assassin's Creed 1 but turned to be a catastrophe.

Now I want to try again. However, I am confused as to which of these packages am I to install, avoiding crashes, clashes, system failures system damage and ensuring running smooth installation of games.

img

I need help regarding compatibility and dependency.

I viewed this answer and as per the update & want the latest developing branch.

Update :

On trying to install wine through terminal, I get this error :

ved [ ~ ] >>>> sudo apt-get install wine
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
wine : Depends: wine1.5 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
ved [ ~ ] >>>> sudo apt-get build-dep wine
Reading package lists... Done
Building dependency tree
Reading state information... Done
Picking 'wine1.5' as source package instead of 'wine'
The following packages have unmet dependencies:
libgl1-mesa-dev : Depends: mesa-common-dev (= 8.0.4-0ubuntu0.2) but it is not going to be installed
Depends: libgl1-mesa-glx (= 8.0.4-0ubuntu0.2) but 9.1~git20121025.86cd77d0-0ubuntu0ricotz2~precise is to be installed
libglu1-mesa-dev : Depends: libglu1-mesa (= 8.0.4-0ubuntu0.2) but 9.0.0-0ubuntu1~precise1 is to be installed
E: Build-dependencies for wine could not be satisfied.

I tried to install dependencies but no success. Also, sudo apt-get -f install didn't work. If I run sudo apt-get -f install wine1.5, it gives unmet dependency as

The following packages have unmet dependencies:
wine1.5 : Depends: wine1.5-i386 (= 1.5.20-0ubuntu2)
E: Unable to correct problems, you have held broken packages.

and on attempting to install wine1.5-i386,

The following packages have unmet dependencies:
wine1.5-i386:i386 : Depends: libgl1-mesa-glx:i386 but it is not going to be installed or
libgl1:i386
Depends: libglu1-mesa:i386 but it is not going to be installed or
libglu1:i386
E: Unable to correct problems, you have held broken packages.

What else do I do?

share|improve this question

2 Answers 2

Wine Windows Programmloader is wine itself. I suggest you to use PlayonLinux its a great GUI for managing the installation of programms using wine and comes with many scripts for programminstalls. It will either download a preferred wine version for each programm (if there is an installscript given for that one).

enter image description here

share|improve this answer
    
So PlayonLinux installs WINE and an additional GUI? –  VedVals Dec 10 '12 at 10:23
    
Playonlinux is an additional GUI. And it will install wine for you. –  termnml Dec 10 '12 at 10:27

The best way is to install it via terminal. (or you can use Synaptic)

sudo apt-get install wine

This will install wine and all packages that are needed. In Ubuntu 12.04 it will install Wine 1.4.

If you want to use Wine 1.5 you can use a PPA

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get install wine1.5

If you try to install specific Windows software, you should have a look on this site: http://appdb.winehq.org/

There you can find additional infos what you need for which software.

share|improve this answer
    
Gives error. Can't install wine –  VedVals Dec 10 '12 at 10:50
    
@VedVals could you specify the error? Or is Can't install wine the error you get? Cheers –  Mochan Dec 10 '12 at 11:31
    
@Mochan Question updated with error. Tried build-dep with no success. –  VedVals Dec 10 '12 at 14:22
    
I see. Please take a look at this answer on how to solve unmet dependencies, as it will probably help. If this doesn't help, let me know :) –  Mochan Dec 10 '12 at 21:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.