Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

when i try install openjdk-7-jre-headless i am getting the following error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  ca-certificates-java icedtea-7-jre-jamvm java-common libcups2 libjpeg62 liblcms2-2 libnspr4 libnss3 libnss3-1d openjdk-7-jre-lib tzdata tzdata-java
Suggested packages:
  default-jre equivs cups-common liblcms2-utils libnss-mdns sun-java6-fonts ttf-dejavu-extra ttf-baekmuk ttf-unfonts ttf-unfonts-core ttf-sazanami-gothic
  ttf-kochi-gothic ttf-sazanami-mincho ttf-kochi-mincho ttf-wqy-microhei ttf-wqy-zenhei ttf-indic-fonts-core ttf-telugu-fonts ttf-oriya-fonts
  ttf-kannada-fonts ttf-bengali-fonts
The following NEW packages will be installed:
  ca-certificates-java icedtea-7-jre-jamvm java-common libcups2 libjpeg62 liblcms2-2 libnspr4 libnss3 libnss3-1d openjdk-7-jre-headless openjdk-7-jre-lib
  tzdata-java
The following packages will be upgraded:
  tzdata
1 upgraded, 12 newly installed, 0 to remove and 122 not upgraded.
Need to get 41.2 MB/43.5 MB of archives.
After this operation, 64.0 MB of additional disk space will be used.

Get:5 http://in.archive.ubuntu.com/ubuntu/ oneiric/main java-common all 0.42ubuntu2 [62.4 kB]
Fetched 41.1 MB in 4min 5s (167 kB/s)
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/j/java-common/java-common_0.42ubuntu2_all.deb  Size mismatch
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

am unable to solve this. Am i missing something? please help me out in solving this.

share|improve this question

1 Answer 1

Use software-properties-gtk to set your download location to either the Main server, or something close to your location. Afterwards, run sudo apt-get update to refresh packages cache, and try installing the failing package again.

share|improve this answer
    
apt-get install software-properties-gtk shows the dependencies as openjdk-6-jre-lib which inturn show the depends on java-common which inturn points to openjdk-6-jre-lib. Its like a cyclic dependencies. –  siddanth Dec 10 '12 at 10:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.