Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I put Ubuntu on an Acer Aspire 3690 Laptop (replaced Windows Vista). Everything seems to work fine except the wireless connection. It says FIRMWARE MISSING. It detects that I have a wireless card, so I don't know what to do. I've already used the ADDITIONAL DRIVERS thing, and that didn't work. I've googled and have not found anything helpful.

I don't really know what I'm doing, so can your directions please be kindergarten level? Thank you very much for any help you can provide. I really appreciate it.

share|improve this question
    
Welcome to Ask Ubuntu, drew. You might consider adding what version of Ubuntu you have installed. Is it 12.04 (the first one on this page) or 12.10 (the second one on this page)? Or did you install an earlier version? Have fun! :) –  Mochan Dec 10 '12 at 5:56
add comment

1 Answer 1

I think the new kernel and broadcom drivers are the reason for the problem.


Open your terminal

  • Click the Dash Icon on the Top-Left of the Screen
  • Type Terminal
  • Click the Black Icon that appears.

Execute the commands
Type the following command.

sudo apt-get install linux-headers-generic  

Press Enter, and you will be prompted for your password. Enter your password, and press Enter

Now, type the following command

sudo apt-get install --reinstall bcmwl-kernel-source  

Press Enter. Now, type the following command

sudo modprobe wl   

Now your wireless should start working.


Source:

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.