Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't change the screen brightness on my laptop (Asus G53JW) with 12.10 installed. I have tried many ways to solve the problem, but nothing worked. I tried to edit grub with acpi_vendor and acpi_osi (I have tried all the combinations found on the ubuntu.org forum but still I can't change it. I even tried to add in xorg.conf the string:

Option “RegistryDwords” “EnableBrightnessControl=1″

Nothing changed. The only way to get it to work is to use nvidiabl but I have flickering problems with it and I'd like to find a way to solve the problem without external modules like nvidiabl.

share|improve this question
1  
Welcome to Ask Ubuntu. In your questions to come, please do not add personal details and unneeded text like: "My English is no good". Many editors are here to correct English so there is no worry about your skills with the language. Please also tag the main problem. The Brightness tag is most suited because you are experiencing problems with the brightness. Hope you have a great time on Ask Ubuntu! :) –  Mochan Dec 10 '12 at 5:49
    
Let me know if this works: "sudo setpci -s '00:02.0' F4.B=xy" (remove "s) where xy is a hex number. Try 5b, 40, etc for xy and let me know if brightness changes (Digits are 0, ..., 9, a(10), b(11), ..., f(15). Range is 00 - ff. 256 levels. Brightness value of xy = x*16 + y). I'm not sure that it'll work though without nvidiabl, but can't hurt to try. If it works, then you can map the command to keyboard shortcuts (after making it executable without requiring password). –  S Prasanth Dec 10 '12 at 7:44

4 Answers 4

Install this program from Ubuntu Software Center. It should work fine.

You can control brightness using this slider.

share|improve this answer

I also have this problem for as long as you and I just found a solution, but for Ubuntu 14.04. Take a look here.

share|improve this answer

I have an Acer Aspire S7-191, installed Ubuntu 14-04 LTS. The brightness control, using the keyboard function keys, did not work The following process resolved this issue:

  1. Open Terminal with Ctrl + Alt + T
  2. Type sudo gedit /etc/default/grub [enter your root password when asked]
  3. change the line which reads GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="acpi_backlight=vendor"
  4. Save and Close gedit.
  5. Then update Grub with sudo update-grub
  6. Then re-start
share|improve this answer

I had the same problem, and found this:

xrandr --output LVDS1 --brightness "X"

Where X is between 1 (full brightness) and 0 (backlight off) Hope it helps :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.