Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.10 on my Dell Studio 1747. The laptop fan is up and running as soon as the Ubuntu log on screen appears (even when the laptop is cold). The laptop ends up overheating and turning off. Do I need to install the correct drivers for my laptop? I don't know how to or where to begin. Any help would be appreciated. Thanks.

share|improve this question
    
Installing drivers is a windowsism... if it's overheating, it's a hardware problem. –  psusi Dec 10 '12 at 4:08
2  
This is not always correct some laptops need extra drivers. –  coteyr Dec 10 '12 at 5:49
    
@psusi "Installing drivers" is not Windows-specific language. People used that term before Windows 1 was released. Canonical uses that term in reference to Ubuntu. –  Eliah Kagan Jan 19 '13 at 11:30
    
@PJ Singh, make sure that you have drivers for your graphic card installed on your system. Please paste the results of lspci | grep -i VGA by editing your question. I too had this fan problem; installing the graphic card drivers helped me alot. –  Ankit Jan 19 '13 at 11:43
    
@EliahKagan, Properly supported hardware has drivers included in the Linux kernel and loaded automatically. It is only in the world of Windows where you have hardware vendors that have to provide their own drivers as an after market add on you have to go get and install yourself. The only time you see this with Linux is when the manufacturer does not provide specs needed for a driver to be written, and only provides a windows driver, and so the only way to get the hardware to work is to use the windows driver in emulation. Either way, lack of a driver has nothing to do with overheating. –  psusi Jan 20 '13 at 5:20
show 1 more comment

2 Answers

Most fan problems I have seen have been due to one of three issues. In order from common to least common they are:

  1. Dirty Fans - Check your fans, make sure they are clean, make sure there is no dust or blockage. Fans work differently in Linux (speed up and slow down at different times) and they assume a lack of garbage in the airflow path. I have seen this lead to overheating.
  2. Bad hardware setup - The Studio 1747 had some problems with it's wireless card at one point. This site seems to indicate it has been fixed, however I have seen some broadcom chips "over heat" and thus push other temperatures up enough to cause a thermal event. Take into consideration any hardware that might heat up and cause other things to heat up.
  3. Wrong fan speed - This is rare, but can happen. Try using fan_control to manually control the speed. See this posting. Controlling your fans manually should be the last answer, but it is possible.

Make sure to record your final results at Ubuntu Friendly.

share|improve this answer
add comment

Modified 23/01/2013 responded to MHC and from my true experiences. -------------MHC==> post above <===

You might have not installed the proprietary drivers. The open source drivers (especially for AMD/ATI cards) are known for their poor power and heat management. – MHC Jan 19 at 14:36

I found out that after 5 continuos days of testing reimaging and re-installations. Not to go into details of the test here, being not a right thread or post.

Summery.

Hp dv6-6137tx with AMD Radeon

Ubuntu 12.04 with the default driver from Ubuntu fresh installation will run notebooks hotter at 60-78 Degree C = running with 3D-Unity or 2D-Unity.

After activate successful AMD driver, it run colder to 45-65 Degree C. (Note=AMD driver I cannot login to 3D unity at all) Deactivate AMD driver (even with jupiter and cpufreq on powersave) went back to 60-78 C.

Ubuntu 12.10 has issue with AMD driver and default drivers runing hot at 65-80 Degree C

edit 28/01/2013 Now I manage Ubuntu 12.10 to do more complex installation of AMD driver from http://wiki.cchtml.com/index.php/Ubuntu_Oneiric_Installation_Guide#Updated_Open_Source_Driver_PPA.27s

I got this Hp dv6-6137tx stabilized 52-65 Degree C. No more noisy fan now.

=================

Fujitsq Lifebook L-532 with Nvdia Geforce.

Ubuntu 12.04 with the i-951 default driver from Ubuntu fresh installation will run notebooks colder, 43-63 Degree C. I could not find a way to install Nevdia Geforce driver (2nd VGA card on the main board).

Ubuntu 12.10 has issue with default drivers run hotter, 60-80 Degree C.

I could not find a way to install Nevdia Geforce yet.

In many posts =>said, being the "2nd VGA card on board", Linux has to be tweaked and twisted. So it is out of my ability and time.

I end up using 12.04 on both notebooks and skip Ubuntu 12.10 for the moments.

as of 28/01/2013 now I got hp dv6-6137tx running ok with 12.10 too.

=============================================================================

And I finally found that jupiter and cpufreq are minors factors. They help only 3-5 degree C drops when I disable or uninstalled them.

But I still have them installed for the sake of those 3-5 Degree C.

The right VGA drivers are the most crucial parts of running Ubuntu Notebook cold. ========================================================o======================== And it is very crucial that you must at least install "indicator-sensors" to let you know the real status of temperature.

And do not use Ubuntu versions that will "end" your computer with 65-80 Degree C.

That will finally destroy your notebook, like what happen to my notebook.

Open "Terminal" --> Click on "Dash home" icon (ubuntu logo on the top left hand corner) then key in "Ter" in the search box. Click on "Terminal" Just copy the following comand lines start mostly with "sudo", and paste into the Terminal's prompt.


1. Install indicator-sensors:

    sudo add-apt-repository ppa:alexmurray/indicator-sensors
    sudo apt-get update
    sudo apt-get install indicator-sensors
    indicator-sensors

The last line will install the indicator on the panel, but if you close the terminal your indicator will close as well.


Or, click on "Dash home" icon (the Ubuntu logo on the top left hand corner). Type in in the search box and click on "Hardware Sensor Indicator". Immediately, there should be one small black window appears on the top panel. Click on it, then select preference to set the GUI config of your choice.

Don't forget to tick the box "Autostart" check box if you want it to autostart.


2. Then do either or both of 2.1 and 2.2:

2.1 Install Jupiter

sudo add-apt-repository ppa:webupd8team/jupiter
sudo apt-get update
sudo apt-get install jupiter

Click on "Dash home" icon (ubuntu logo on the top left hand corner) key in "ju" in the search box and click on "jupiter".

Immediately, there should be one small jupiter icon appears on the top panel. Click on it, then select performance to set the "Power Saving" . jipiter will set "Autostart" by default, so you don't have to do anything for next boot.


2.2 Install "indicator-cpufreq"

sudo add-apt-repository ppa:artfwo/ppa
sudo apt-get update
sudo apt-get install indicator-cpufreq
indicator-cpufreq

The last line would take 15-30 seconds before it appear on the panel. Then you click on the indicator-cpufreq icon to pick "Powersave" option.


To make sure it auto start next boot. Click on "Dash home" icon (ubuntu logo on the top left hand corner) key in "sta" in the search box and click on "Starup Application". Make sure the "CPU Frequency Scaling Indicator" which is "indicator-cpufreq", is on the list too.

If some how it is not in there,

Click "Add",

Copy " indicator-cpufreq " (without the quote) into all three boxes.

Then Click "Add".


I finally chose both, since it seem to have more controls.

Important Point/Notice:

It seemed to work only after using for a little while and after 2 or 3 reboots. It seemed not to work at all after the 1st reboot.So be patient and give them a trial, and choose "Powersave" option.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.