Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I see that I can delete networks that my machine "remembers" from nm-applet by clicking on the wireless icon in the panel and selecting "edit connections" -> "wireless". However, sometimes I click on the wrong wireless connection by accident in the dropdown list. If the connection is secure, the machine of course never successfully connects, but somehow it still seems to memorize the ESSID. Whenever I'm in range of that wireless, it now tries to connect.

Worse, if not connected to any other network, it repeatedly prompts me to connect to this network. If left unattended, I may find dozens of copies of the window prompting me to log in to this mistaken network. There must be a file somewhere that records this connection ID, but I cannot find it. The only connections appearing in the "edit connections" I mention above are those to which I've actually connected. How do I find the file and delete the line corresponding to the offending "memorized" network?

EDIT I seek a solution to remove those networks from whatever list they get added to when I first select them. It appears this behavior is a bug in the network manager(?)

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted
+50

have you tried to delete the files in the directory /etc/NetworkManager/system-connections/ ?

You should have 1 file for every net you have tried to connect, open a terminal and use the commands:

sudo ls -l /etc/NetworkManager/system-connections/

To list all the files, after you have found the network that you want to delete, remove them with the command:

sudo rm /etc/NetworkManager/system-connections/NETWORK_NAME
share|improve this answer
    
Awesome, thanks! I wonder why this list is different than the one provided in the Network Applet GUI? –  cboettig Jan 5 '13 at 19:47
add comment

If your major problem are those annoying prompts asking you to log in to a network, then whenever you are not using Wireless, you can just Disable Wireless by clicking the Enable Wireless entry in your Network Indicator Menu.

share|improve this answer
    
Yeah, that's my current solution in a poor connectivity area. However, I usually do not get prompted unless I have attempted to connect to that network before. If I have connected successfully, I can delete it from the list and not get prompted about it. My question is about where to find the record for networks that do not show up there but are clearly memorized by the machine. The record file must exist somewhere –  cboettig Dec 10 '12 at 17:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.