Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use dual monitor for my laptop, I work on my laptop and watch TV or Youtube on the external monitor [which is far from my laptop]

whenever firefox or chrome in ubuntu pops up, [for example to upload a file] or it pop up in the External monitor, how can I force it to pop up in the same monitor that I am working on ? [ usualy laptop one ]

share|improve this question

You can use the CompizConfig Settings Manager to control how windows are placed with multiple monitors. First you'll need to install it:

sudo apt-get install compizconfig-settings-manager

CCSM will now show up in the Dash or can be run from the command line with


In the "Window Management" category you should see a "Place Windows" button. Click on this and go to the "General" tab. You should see an option there called "Multi Output Mode" with a dropdown box. Try changing this to either "Use output device with pointer", which will open windows on the monitor where your mouse pointer is currently, or "Use output device of focussed window", which will open new windows on the monitor where the currently focussed window is located.

share|improve this answer
Thank you so much, it feels so good now, you are a life saver ! – Medya Dec 9 '12 at 22:33
Ooops I just tried it again with Chrome, when I uploaded a file it opened in the next mintor :( is it for only firefox ? – Medya Dec 10 '12 at 0:04
I'm not really sure. I've not had any windows placed incorrectly after changing this setting, but I don't use Chrome. Do any other applications still have windows open on the wrong monitor? – Andrew Johnson Dec 10 '12 at 0:13
:( it is really annoying, when I click on any image in my folders to open, it exactly pop up in the OTHER monitor, I dont know why I felt like it was fixed for a few seconds... :( – Medya Dec 10 '12 at 3:32
it is really interesting I DISABLED the place window in the CCSM and now it works fine ! isnt that strange ? – Medya Dec 10 '12 at 3:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.