Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've used XBMC live in the past and have been happy with manually editing /etc/fstab to configure disks to automatically mount.

Now I am running Ubuntu 12.10. Within "disks" i have the mount options on the drives set to "Automatic Mount Options: On" but the disks are'nt mounted until I access them.

The disks aren't listed in /etc/fstab- I could add them by hand, but I am expecting the GUI to take care of it?

Is there something i'm missing?

share|improve this question

3 Answers 3

Don't use 'Automatic Mount Options: On'! That just sets it to use the default options for automounting, which for me at least apparently means that the drive isn't automounted. This is perhaps a tad confusing, as you might expect the greyed out settings below to show the default settings, but they don't.

Instead, you should set 'Automatic Mount Options' to 'Off' and make sure the 'Mount at startup' and 'Show in user interface' checkboxes are selected manually. You might also want to change the 'Mount Point' to something more readable and useful that /mnt/[UUID] or whatever it defaults to.

I know this question is pretty old, but it still comes up on searches and is still relevant to new versions, so I thought it useful to answer properly. Hope this helps someone.

share|improve this answer
up vote 1 down vote accepted

I managed to get them automounting using AriOS Automount. I'll wait to see if anyone can explain why ubuntu isn't doing what I expect it to do naturally before accepting my own answer.

share|improve this answer

the answer u r expecting might be pySDM, its very useful - In terminal type -

sudo apt-get install pysdm

and then please follow the link -

Mount Partitions & External Devices at boot time

P.S - I am using Ubuntu 12.04. Hope this helps.

share|improve this answer
    
so am I misunderstanding what the "automatic mount options" should do? –  Lee Tickett Dec 9 '12 at 19:18
1  
try it - open the automatic mount option interface and turn it off. Then tick on "MOUNT AT STARTUP". write in the options textbox right below the "icon name"- ,umask=027,owner. Mention the mount point if it is not already there as /media/<anything>. –  Arin Chakraborty Dec 9 '12 at 19:44
1  
an error occurred while mounting /mnt/xxx press s to skip mounting or m for manual recovery –  Lee Tickett Dec 9 '12 at 20:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.