Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I start my computer, I get a text login--it doesn't even load lightdm. Dmesg gives me this:

[   42.367035] NVRM: API mismatch: the client has the version 304.43, but
[   42.367038] NVRM: this kernel module has the version 310.14.  Please
[   42.367040] NVRM: make sure that this kernel module and all NVIDIA driver
[   42.367041] NVRM: components have the same version.
[   42.619472] init: lightdm main process (1235) terminated with status 1
[   48.041960] vboxdrv: Found 1 processor cores.
[   48.044418] vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
[   48.044422] vboxdrv: Successfully loaded version 4.1.12_Ubuntu (interface 0x00190000).
[   48.459287] vboxpci: IOMMU not found (not registered)
[   50.544026] wlan0: no IPv6 routers present
[   52.729171] init: Failed to spawn vsftpd main process: unable to execute: No such file or directory
[   58.435781] init: plymouth-stop pre-start process (2306) terminated with status 1
[   59.169528] init: failsafe-x main process (1429) terminated with status 1

I don't know how much of this is relevant. I think this problem started around when I tried to install new proprietary NVIDIA drivers.

How can I get X back? I would install older drivers using the Additional Drivers program, except I can't start any version of X.

share|improve this question

I had this same problem. It was caused by a failed installation of the 310 version of the nvidia drivers. I fixed it with

apt-get remove nvidia-experimental-310

After that I could start X.

share|improve this answer
Had something similiar. Both 304 and 310 were installed, which led to the problem in the question. Removing 304 fixed it. – panmari Jun 22 '13 at 10:04

Important! Read this entire post before trying!

Go to a terminal by pressing CTRL+ALT+F3. Login, and enter this command:

sudo apt-get purge nvidia-*

That will remove the proprietary drivers. Once it's done, backup your Xorg.conf, like so:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak~

Then run this:

sudo update-initramfs -u

This updates the RAMFS, which seems to help (forget why though, sorry). Then reboot using this:

sudo reboot
share|improve this answer

I got a similar error as I was installing CUDA for Ubuntu 12.10 which is not yet fully supported by NVidia (they have 11.10 as the newer version.)

The problem was indeed a mix of libraries. I had to completely remove all libraries installed by default when installing Ubuntu and then make sure to reinstall the CUDA driver.

To get a list of the default nvidia packages installed:

dpkg -l | grep nvidia

To remove them:

apt-get remove --purge nvidia-...

Obviously the other solutions presented here would not work in case you were installing CUDA since reinstalling the default libraries & drivers would overwrite the CUDA installation!

In the newer versions of Ubuntu (since at least 13.10), CUDA can be installed using:

sudo apt-get install nvidia-cuda-dev
sudo apt-get install nvidia-cuda-doc
sudo apt-get install nvidia-cuda-dbg
sudo apt-get install nvidia-cuda-toolkit

These commands should automatically install the cuda library if not already installed.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.