Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I don't know what is causing this. I've noticed lately after upgrading the computer at church to Ubuntu 12.10, the sound recorder will not record when the record button is pressed, and when I press it again, the message to continue without saving comes up. No matter what I choose the program completely locks up, and the only way I can quit the program is by going to system monitor and ending the process, I then reopen the sound recorder and it then works properly. Any thoughts as to what can be done to fix this?

share|improve this question
1  
not your solution but meanwhile you can use Audacity for your recording until you fix it! –  Stefano Mtangoo Apr 25 '13 at 22:54

1 Answer 1

I was having this problem too. While looking for alternatives I ran into audio-recorder (https://launchpad.net/~osmoma/+archive/audio-recorder) and when I installed it, I noticed that it also installed several gstreamer related libraries (which I remember having previouly but probably were uninstalled during my upgrade to 12.10).

So, out of curiosity I tried the sound recorder again after the gstreamer libraries were installed, and what do you know, it was working fine now.

So, short answer is: It looks like the problem is that you are missing some gstreamer libraries.

This is the list of extra packages that was installed by audio-recorder (and which fixed my problem): gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-pulseaudio gstreamer1.0-x libgstreamer-plugins-base1.0-0 libgstreamer1.0-0

So, although I can't be sure which of them actually fixed sound recorder, I am sure it was one of them. :).

share|improve this answer
    
I was having the same issue, also on 12.10. I looked for all those packages you listed in Synaptic, and I had all of them except for gstreamer1.0-pulseaudio. Unfortunately, installing it did not fix the problem. –  Bravery Onions Apr 26 '13 at 13:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.