Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My problem is that my second display is white. The things I've tried is: System settings > Displays > enable display. Then I get: required virtual size does not fit available size: requested=(3840, 1200), minimum=(320, 200), maximum=(1920, 1920)

I downloaded the latest driver and CCC. Then I tried to use Catalyst Control Center and enabling the display there, then where I got the white display after rebooting.

This is how my driver looks like:

$ lspci | grep VGA 01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Cayman XT [Radeon HD 6970]

This is how my X11 xorg.conf look like:

Section "ServerLayout"
Identifier "amdcccle Layout"
Screen 0 "amdcccle-Screen[1]-0" 0 0
Screen "amdcccle-Screen[1]-1" 1920 0
EndSection

Section "Module"
Load "glx"
EndSection

Section "Monitor"
Identifier "0-DFP9"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
Option "TargetRefresh" "60"
Option "Position" "0 0"
Option "Rotate" "normal"
Option "Disable" "false"
Option "PreferredMode" "1920x1080"
EndSection

Section "Monitor"
Identifier "0-DFP11"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
Option "PreferredMode" "1920x1200"
Option "TargetRefresh" "60"
Option "Position" "0 0"
Option "Rotate" "normal"
Option "Disable" "false"
EndSection

Section "Device"
Identifier "amdcccle-Device[1]-0"
Driver "fglrx"
Option "Monitor-DFP9" "0-DFP9"
BusID "PCI:1:0:0"
EndSection

Section "Device"
Identifier "amdcccle-Device[1]-1"
Driver "fglrx"
Option "Monitor-DFP11" "0-DFP11"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Default Screen"
DefaultDepth 24
EndSection

Section "Screen"
Identifier "amdcccle-Screen[1]-0"
Device "amdcccle-Device[1]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "amdcccle-Screen[1]-1"
Device "amdcccle-Device[1]-1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

share|improve this question

1 Answer 1

I've had success solving a similar problem in the past doing the following. First unplug the second display and run:

sudo aticonfig --initial

This will reinitialize your xorg.conf. Now reboot your machine. After the reboot, plug the second display back in, run

gksu amdcccle

and configure the displays how you like. Note that if you run the Catalyst Control Center from the dash, it won't have root permissions and won't be able to save your configuration to xorg.conf.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.